{"answers":{"affected":"2 open source packages ship an affected version, including pannellum. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16763 in the wild and no public exploit code.","fix":"Upgrade pannellum to 2.5.5 or later.","what":"CVE-2019-16763 is a medium-severity cross-site scripting vulnerability in mpretroff pannellum, published on 22 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-16763 and fix it if it is affected.\n\nWhat it is: CVE-2019-16763 is a medium-severity cross-site scripting vulnerability in mpretroff pannellum, published on 22 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-16763 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pannellum (npm): affected from 2.5.0; fixed in 2.5.5\n- pannellum (npm): affected from 2.5.0; fixed in 2.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16763/ (Markdown: https://insights.sbomify.com/CVE-2019-16763/index.md)","id":"CVE-2019-16763","markdown":"https://insights.sbomify.com/CVE-2019-16763/index.md","name":"CVE-2019-16763","record":{"aliases":["GHSA-m52x-29pq-w3vv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Pannellum library","requires_auth":"high_privilege","summary":"Attackers can execute XSS via unsanitized URLs in Pannellum, potentially accessing user data or hijacking accounts if users click malicious hotspots.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pannellum","vendor":"pannellum"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Pannellum from 2.5.0 through 2.5.4 URLs were not sanitized for data URIs (or vbscript:), allowing for potential XSS attacks. Such an attack would require a user to click on a hot spot to execute and would require an attacker-provided configuration. The most plausible potential attack would be if pannellum.htm was hosted on a domain that shared cookies with the targeted site's user authentication; an \u0026lt;iframe\u0026gt; could then be embedded on the attacker's site using pannellum.htm from the targeted site, which would allow the attacker to potentially access information from the targeted site as the authenticated user (or worse if the targeted site did not have adequate CSRF protections) if the user clicked on a hot spot in the attacker's embedded panorama viewer. This was patched in version 2.5.5.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS in Pannellum from 2.5.0 through 2.5.4","id":"CVE-2019-16763","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"PowAssent is susceptible to denial of service attacks","id":"CVE-2019-16764"},"packages":[{"ecosystem":"npm","fixed":["2.5.5"],"introduced":["2.5.0"],"last_affected":[],"package":"pannellum","purl":null,"source":"GHSA-m52x-29pq-w3vv"},{"ecosystem":"npm","fixed":["2.5.5"],"introduced":["2.5.0"],"last_affected":[],"package":"pannellum","purl":"pkg:npm/pannellum","source":"GHSA-m52x-29pq-w3vv"}],"prev":{"headline":"Validator parsing discrepancy due to string encoding in NPM slpjs","id":"CVE-2019-16762"},"products":["pannellum"],"published":"2019-11-22","related":[{"cvss_score":5.3,"headline":"Pannellum has a XSS vulnerability in hot spot attributes","id":"CVE-2026-27210","kev_date_added":null,"published":"2026-02-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["mpretroff"]},"summary":"Attackers can execute XSS via unsanitized URLs in Pannellum, potentially accessing user data or hijacking accounts if users click malicious hotspots.","url":"https://insights.sbomify.com/CVE-2019-16763/"}