# CVE-2019-16763: XSS in Pannellum from 2.5.0 through 2.5.4

> Attackers can execute XSS via unsanitized URLs in Pannellum, potentially accessing user data or hijacking accounts if users click malicious hotspots.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m52x-29pq-w3vv

## What is CVE-2019-16763?

CVE-2019-16763 is a medium-severity cross-site scripting vulnerability in mpretroff pannellum, published on 22 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

In Pannellum from 2.5.0 through 2.5.4 URLs were not sanitized for data URIs (or vbscript:), allowing for potential XSS attacks. Such an attack would require a user to click on a hot spot to execute and would require an attacker-provided configuration. The most plausible potential attack would be if pannellum.htm was hosted on a domain that shared cookies with the targeted site's user authentication; an &lt;iframe&gt; could then be embedded on the attacker's site using pannellum.htm from the targeted site, which would allow the attacker to potentially access information from the targeted site as the authenticated user (or worse if the targeted site did not have adequate CSRF protections) if the user clicked on a hot spot in the attacker's embedded panorama viewer. This was patched in version 2.5.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-16763?

2 open source packages ship an affected version, including pannellum. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pannellum` | npm | From 2.5.0 | 2.5.5 |
| `pannellum` | npm | From 2.5.0 | 2.5.5 |

Products: Pannellum Pannellum.

## How do I fix CVE-2019-16763?

Upgrade pannellum to 2.5.5 or later.

## Is CVE-2019-16763 being exploited?

There is no known exploitation of CVE-2019-16763 in the wild and no public exploit code.

## Other vulnerabilities in mpretroff pannellum

- [CVE-2026-27210](https://insights.sbomify.com/CVE-2026-27210/): Pannellum has a XSS vulnerability in hot spot attributes (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16763 and fix it if it is affected.

What it is: CVE-2019-16763 is a medium-severity cross-site scripting vulnerability in mpretroff pannellum, published on 22 Nov 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-16763 in the wild and no public exploit code.

Affected packages and fixed versions:
- pannellum (npm): affected from 2.5.0; fixed in 2.5.5
- pannellum (npm): affected from 2.5.0; fixed in 2.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16763/ (Markdown: https://insights.sbomify.com/CVE-2019-16763/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16763
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16763
- OSV: https://osv.dev/vulnerability/CVE-2019-16763

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16763/
Summaries are generated and may contain mistakes; the official description above is the record.
