{"answers":{"affected":"2 open source packages ship an affected version, including pow_assent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16764 in the wild and no public exploit code.","fix":"Upgrade pow_assent to 0.4.4 or later.","what":"CVE-2019-16764 is a medium-severity denial of service vulnerability in pow-auth pow_assent, published on 25 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-16764 and fix it if it is affected.\n\nWhat it is: CVE-2019-16764 is a medium-severity denial of service vulnerability in pow-auth pow_assent, published on 25 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-16764 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pow_assent (Hex): affected all versions; fixed in 0.4.4\n- pow_assent (Hex): affected all versions; fixed in 0.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16764/ (Markdown: https://insights.sbomify.com/CVE-2019-16764/index.md)","id":"CVE-2019-16764","markdown":"https://insights.sbomify.com/CVE-2019-16764/index.md","name":"CVE-2019-16764","record":{"aliases":["GHSA-368c-xvrv-x986","GHSA-5653-437f-5hmc"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Elixir authentication library","requires_auth":"low_privilege","summary":"Attackers can crash the application by exhausting the atom table via user-controlled input in PowAssent, requiring a library update.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"powassent","vendor":"powauth"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"The use of `String.to_atom/1` in PowAssent is susceptible to denial of service attacks. In `PowAssent.Phoenix.AuthorizationController` a value is fetched from the user provided params, and `String.to_atom/1` is used to convert the binary value to an atom so it can be used to fetch the provider configuration value. This is unsafe as it is user provided data, and can be used to fill up the whole atom table of ~1M which will cause the app to crash.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PowAssent is susceptible to denial of service attacks","id":"CVE-2019-16764","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"Code injection in vscode-codeql","id":"CVE-2019-16765"},"packages":[{"ecosystem":"Hex","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"pow_assent","purl":null,"source":"GHSA-5653-437f-5hmc"},{"ecosystem":"Hex","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"pow_assent","purl":"pkg:hex/pow_assent","source":"GHSA-5653-437f-5hmc"}],"prev":{"headline":"XSS in Pannellum from 2.5.0 through 2.5.4","id":"CVE-2019-16763"},"products":["pow_assent"],"published":"2019-11-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["pow-auth"]},"summary":"Attackers can crash the application by exhausting the atom table via user-controlled input in PowAssent, requiring a library update.","url":"https://insights.sbomify.com/CVE-2019-16764/"}