# CVE-2019-16764: PowAssent is susceptible to denial of service attacks

> Attackers can crash the application by exhausting the atom table via user-controlled input in PowAssent, requiring a library update.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-368c-xvrv-x986, GHSA-5653-437f-5hmc

## What is CVE-2019-16764?

CVE-2019-16764 is a medium-severity denial of service vulnerability in pow-auth pow_assent, published on 25 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The use of `String.to_atom/1` in PowAssent is susceptible to denial of service attacks. In `PowAssent.Phoenix.AuthorizationController` a value is fetched from the user provided params, and `String.to_atom/1` is used to convert the binary value to an atom so it can be used to fetch the provider configuration value. This is unsafe as it is user provided data, and can be used to fill up the whole atom table of ~1M which will cause the app to crash.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2019-16764?

2 open source packages ship an affected version, including pow_assent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pow_assent` | Hex | All versions | 0.4.4 |
| `pow_assent` | Hex | All versions | 0.4.4 |

Products: Powauth Powassent.

## How do I fix CVE-2019-16764?

Upgrade pow_assent to 0.4.4 or later.

## Is CVE-2019-16764 being exploited?

There is no known exploitation of CVE-2019-16764 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16764 and fix it if it is affected.

What it is: CVE-2019-16764 is a medium-severity denial of service vulnerability in pow-auth pow_assent, published on 25 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16764 in the wild and no public exploit code.

Affected packages and fixed versions:
- pow_assent (Hex): affected all versions; fixed in 0.4.4
- pow_assent (Hex): affected all versions; fixed in 0.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16764/ (Markdown: https://insights.sbomify.com/CVE-2019-16764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16764
- OSV: https://osv.dev/vulnerability/CVE-2019-16764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16764/
Summaries are generated and may contain mistakes; the official description above is the record.
