# CVE-2019-16766: 2FA bypass in Wagtail through new device path

> Attackers with valid credentials can bypass two-factor authentication by manipulating the URL to add a new device and gain full CMS access.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-89px-ww3j-g2mm, PYSEC-2019-135

## What is CVE-2019-16766?

CVE-2019-16766 is a high-severity authentication bypass vulnerability in Lab Digital wagtail-2fa, published on 29 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

When using wagtail-2fa before 1.3.0, if someone gains access to someone's Wagtail login credentials, they can log into the CMS and bypass the 2FA check by changing the URL. They can then add a new device and gain full access to the CMS. This problem has been patched in version 1.3.0.

Weakness: CWE-304 (Missing Critical Step in Authentication), CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2019-16766?

3 open source packages ship an affected version, including wagtail-2fa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail-2fa` | PyPI | All versions | 1.3.0 |
| `wagtail-2fa` | PyPI | All versions | 1.3.0 |
| `wagtail-2fa` | PyPI | All versions | 1.3.0 |

Products: Labdigital Wagtail-2fa.

## How do I fix CVE-2019-16766?

Upgrade wagtail-2fa to 1.3.0 or later.

## Is CVE-2019-16766 being exploited?

There is no known exploitation of CVE-2019-16766 in the wild and no public exploit code.

## Other vulnerabilities in Lab Digital wagtail-2fa

- [CVE-2020-5240](https://insights.sbomify.com/CVE-2020-5240/): 2FA bypass through deleting devices in wagtail-2fa (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16766 and fix it if it is affected.

What it is: CVE-2019-16766 is a high-severity authentication bypass vulnerability in Lab Digital wagtail-2fa, published on 29 Nov 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16766 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail-2fa (PyPI): affected all versions; fixed in 1.3.0
- wagtail-2fa (PyPI): affected all versions; fixed in 1.3.0
- wagtail-2fa (PyPI): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16766/ (Markdown: https://insights.sbomify.com/CVE-2019-16766/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16766
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16766
- OSV: https://osv.dev/vulnerability/CVE-2019-16766

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16766/
Summaries are generated and may contain mistakes; the official description above is the record.
