{"answers":{"affected":"2 open source packages ship an affected version, including serialize-javascript. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16769 in the wild and no public exploit code.","fix":"Upgrade serialize-javascript to 2.1.1 or later.","what":"CVE-2019-16769 is a medium-severity cross-site scripting vulnerability in yahoo serialize-javascript, published on 5 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-16769 and fix it if it is affected.\n\nWhat it is: CVE-2019-16769 is a medium-severity cross-site scripting vulnerability in yahoo serialize-javascript, published on 5 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-16769 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- serialize-javascript (npm): affected all versions; fixed in 2.1.1\n- serialize-javascript (npm): affected all versions; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16769/ (Markdown: https://insights.sbomify.com/CVE-2019-16769/index.md)","id":"CVE-2019-16769","markdown":"https://insights.sbomify.com/CVE-2019-16769/index.md","name":"CVE-2019-16769","record":{"aliases":["CLSA-2026-1774398069","GHSA-h9rv-jmmf-4pgx","ROOT-APP-NPM-CVE-2019-16769"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript serialization library","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via serialized regular expressions in non-Node.js environments, leading to cross-site scripting attacks.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"serialize-javascript","vendor":"verizon"}],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The serialize-javascript npm package before version 2.1.1 is vulnerable to Cross-site Scripting (XSS). It does not properly mitigate against unsafe characters in serialized regular expressions. This vulnerability is not affected on Node.js environment since Node.js's implementation of RegExp.prototype.toString() backslash-escapes all forward slashes in regular expressions. If serialized data of regular expression objects are used in an environment other than Node.js, it is affected by this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Affected versions of serialize-javascript are vulnerable to Cross-site Scripting (XSS)","id":"CVE-2019-16769","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Potential DOS attack in Puma","id":"CVE-2019-16770"},"packages":[{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"serialize-javascript","purl":null,"source":"GHSA-h9rv-jmmf-4pgx"},{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"serialize-javascript","purl":"pkg:npm/serialize-javascript","source":"GHSA-h9rv-jmmf-4pgx"}],"prev":{"headline":"Internal exception message exposure for login action in Sylius","id":"CVE-2019-16768"},"products":["serialize-javascript"],"published":"2019-12-05","related":[{"cvss_score":8.1,"headline":"Insecure serialization leading to RCE in serialize-javascript","id":"CVE-2020-7660","kev_date_added":null,"published":"2020-06-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["yahoo"]},"summary":"An attacker can inject malicious scripts via serialized regular expressions in non-Node.js environments, leading to cross-site scripting attacks.","url":"https://insights.sbomify.com/CVE-2019-16769/"}