{"answers":{"affected":"2 open source packages ship an affected version, including phpfastcache/phpfastcache. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16774 in the wild and no public exploit code.","fix":"Upgrade phpfastcache/phpfastcache to 5.0.13 or later.","what":"CVE-2019-16774 is a medium-severity unsafe deserialization vulnerability in PHPSocialNetwork phpfastcache, published on 12 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-16774 and fix it if it is affected.\n\nWhat it is: CVE-2019-16774 is a medium-severity unsafe deserialization vulnerability in PHPSocialNetwork phpfastcache, published on 12 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-16774 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpfastcache/phpfastcache (Packagist): affected from 5.0.0; fixed in 5.0.13\n- phpfastcache/phpfastcache (Packagist): affected from 5.0.0; fixed in 5.0.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16774/ (Markdown: https://insights.sbomify.com/CVE-2019-16774/index.md)","id":"CVE-2019-16774","markdown":"https://insights.sbomify.com/CVE-2019-16774/index.md","name":"CVE-2019-16774","record":{"aliases":["GHSA-484f-743f-6jx2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP caching library","requires_auth":"low_privilege","summary":"An attacker can achieve code execution via object injection in the cookie driver of the phpfastcache library.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpfastcache","vendor":"phpfastcache"}],"cvss":{"score":4.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"In phpfastcache before 5.1.3, there is a possible object injection vulnerability in cookie driver.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Object injection in cookie driver","id":"CVE-2019-16774","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Unauthorized File Access in npm CLI before before version 6.13.3","id":"CVE-2019-16775"},"packages":[{"ecosystem":"Packagist","fixed":["5.0.13"],"introduced":["5.0.0"],"last_affected":[],"package":"phpfastcache/phpfastcache","purl":null,"source":"GHSA-484f-743f-6jx2"},{"ecosystem":"Packagist","fixed":["5.0.13"],"introduced":["5.0.0"],"last_affected":[],"package":"phpfastcache/phpfastcache","purl":"pkg:composer/phpfastcache/phpfastcache","source":"GHSA-484f-743f-6jx2"}],"prev":{"headline":"regular expressions Cross-Site Scripting (XSS) vulnerability in serialize-to-js","id":"CVE-2019-16772"},"products":["phpfastcache"],"published":"2019-12-12","related":[{"cvss_score":5.4,"headline":"Exposed phpinfo() in PhpFastCache","id":"CVE-2021-37704","kev_date_added":null,"published":"2021-08-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["PHPSocialNetwork"]},"summary":"An attacker can achieve code execution via object injection in the cookie driver of the phpfastcache library.","url":"https://insights.sbomify.com/CVE-2019-16774/"}