# CVE-2019-16774: Object injection in cookie driver

> An attacker can achieve code execution via object injection in the cookie driver of the phpfastcache library.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-484f-743f-6jx2

## What is CVE-2019-16774?

CVE-2019-16774 is a medium-severity unsafe deserialization vulnerability in PHPSocialNetwork phpfastcache, published on 12 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In phpfastcache before 5.1.3, there is a possible object injection vulnerability in cookie driver.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2019-16774?

2 open source packages ship an affected version, including phpfastcache/phpfastcache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpfastcache/phpfastcache` | Packagist | From 5.0.0 | 5.0.13 |
| `phpfastcache/phpfastcache` | Packagist | From 5.0.0 | 5.0.13 |

Products: Phpfastcache Phpfastcache.

## How do I fix CVE-2019-16774?

Upgrade phpfastcache/phpfastcache to 5.0.13 or later.

## Is CVE-2019-16774 being exploited?

There is no known exploitation of CVE-2019-16774 in the wild and no public exploit code.

## Other vulnerabilities in PHPSocialNetwork phpfastcache

- [CVE-2021-37704](https://insights.sbomify.com/CVE-2021-37704/): Exposed phpinfo() in PhpFastCache (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16774 and fix it if it is affected.

What it is: CVE-2019-16774 is a medium-severity unsafe deserialization vulnerability in PHPSocialNetwork phpfastcache, published on 12 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-16774 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpfastcache/phpfastcache (Packagist): affected from 5.0.0; fixed in 5.0.13
- phpfastcache/phpfastcache (Packagist): affected from 5.0.0; fixed in 5.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16774/ (Markdown: https://insights.sbomify.com/CVE-2019-16774/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16774
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16774
- OSV: https://osv.dev/vulnerability/CVE-2019-16774

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16774/
Summaries are generated and may contain mistakes; the official description above is the record.
