{"answers":{"affected":"2 open source packages ship an affected version, including npm. It affects 6 products.","exploited":"There is no known exploitation of CVE-2019-16777 in the wild and no public exploit code.","fix":"Upgrade npm to 6.13.4 or later.","what":"CVE-2019-16777 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 13 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-16777 and fix it if it is affected.\n\nWhat it is: CVE-2019-16777 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 13 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-16777 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- npm (npm): affected all versions; fixed in 6.13.4\n- npm (npm): affected all versions; fixed in 6.13.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16777/ (Markdown: https://insights.sbomify.com/CVE-2019-16777/index.md)","id":"CVE-2019-16777","markdown":"https://insights.sbomify.com/CVE-2019-16777/index.md","name":"CVE-2019-16777","record":{"aliases":["DEBIAN-CVE-2019-16777","GHSA-4328-8hgf-7wjr","MINI-wpcm-v5x2-4prj","UBUNTU-CVE-2019-16777"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"npm CLI","requires_auth":"low_privilege","summary":"Attackers can overwrite existing globally-installed binaries during package installation, potentially leading to code execution or privilege escalation.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"npm","vendor":"npmjs"},{"product":"leap","vendor":"opensuse"},{"product":"graalvm","vendor":"oracle"},{"product":"enterprise_linux","vendor":"redhat"},{"product":"enterprise_linux_eus","vendor":"redhat"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Versions of the npm CLI prior to 6.13.4 are vulnerable to an Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a serve binary, any subsequent installs of packages that also create a serve binary would overwrite the previous serve binary. This behavior is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary File Overwrite in npm CLI","id":"CVE-2019-16777","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:leap","oracle:graalvm","redhat:enterprise_linux","redhat:enterprise_linux_eus"],"type":"path_traversal","year":"2019"},"n_packages":2,"n_references":11,"next":{"headline":"Heap buffer overflow in `UnsortedSegmentSum` in TensorFlow","id":"CVE-2019-16778"},"packages":[{"ecosystem":"npm","fixed":["6.13.4"],"introduced":["0"],"last_affected":[],"package":"npm","purl":null,"source":"GHSA-4328-8hgf-7wjr"},{"ecosystem":"npm","fixed":["6.13.4"],"introduced":["0"],"last_affected":[],"package":"npm","purl":"pkg:npm/npm","source":"GHSA-4328-8hgf-7wjr"}],"prev":{"headline":"Unauthorized File Access in npm CLI before before version 6.13.3","id":"CVE-2019-16776"},"products":["cli"],"published":"2019-12-13","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["npm"]},"summary":"Attackers can overwrite existing globally-installed binaries during package installation, potentially leading to code execution or privilege escalation.","url":"https://insights.sbomify.com/CVE-2019-16777/"}