{"answers":{"affected":"2 open source packages ship an affected version, including excon. It affects 4 products.","exploited":"There is no known exploitation of CVE-2019-16779 in the wild and no public exploit code.","fix":"Upgrade excon to 0.71.0 or later.","what":"CVE-2019-16779 is a medium-severity vulnerability in Debian Debian Linux, published on 16 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-16779 and fix it if it is affected.\n\nWhat it is: CVE-2019-16779 is a medium-severity vulnerability in Debian Debian Linux, published on 16 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-16779 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- excon (RubyGems): affected all versions; fixed in 0.71.0\n- excon (RubyGems): affected all versions; fixed in 0.71.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16779/ (Markdown: https://insights.sbomify.com/CVE-2019-16779/index.md)","id":"CVE-2019-16779","markdown":"https://insights.sbomify.com/CVE-2019-16779/index.md","name":"CVE-2019-16779","record":{"aliases":["DEBIAN-CVE-2019-16779","DLA-2070-1","GHSA-q58g-455p-8vw9","OESA-2021-1420","SUSE-SU-2020:2053-1","UBUNTU-CVE-2019-16779","openSUSE-SU-2020:0036-1","openSUSE-SU-2020:0139-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby HTTP client library","requires_auth":"low_privilege","summary":"A race condition in the excon Ruby library allows attackers to read leaked response data from previous requests via persistent connections.","user_interaction":"required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"excon","vendor":"excon_project"},{"product":"backports_sle","vendor":"opensuse"},{"product":"leap","vendor":"opensuse"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"},{"id":"CWE-664","name":"Improper Control of a Resource Through its Lifetime"}],"description":"In RubyGem excon before 0.71.0, there was a race condition around persistent connections, where a connection which is interrupted (such as by a timeout) would leave data on the socket. Subsequent requests would then read this data, returning content from the previous response. The race condition window appears to be short, and it would be difficult to purposefully exploit this.","ecosystems":["RubyGems","SUSE:Linux Enterprise Module for Containers 12","SUSE:Package Hub 15 SP1","openSUSE:Leap 15.1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"In RubyGem excon, interrupted Persistent Connections May Leak Response Data","id":"CVE-2019-16779","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux","opensuse:backports_sle","opensuse:leap"],"type":"race_condition","year":"2019"},"n_packages":5,"n_references":5,"next":{"headline":"Stored cross-site scripting (XSS) in WordPress block editor","id":"CVE-2019-16780"},"packages":[{"ecosystem":"RubyGems","fixed":["0.71.0"],"introduced":["0"],"last_affected":[],"package":"excon","purl":null,"source":"GHSA-q58g-455p-8vw9"},{"ecosystem":"RubyGems","fixed":["0.71.0"],"introduced":["0"],"last_affected":[],"package":"excon","purl":"pkg:gem/excon","source":"GHSA-q58g-455p-8vw9"},{"ecosystem":"SUSE:Linux Enterprise Module for Containers 12","fixed":["0.52.0-12.3.8"],"introduced":["0"],"last_affected":[],"package":"rubygem-excon","purl":"pkg:rpm/suse/rubygem-excon\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Containers%2012","source":"SUSE-SU-2020:2053-1"},{"ecosystem":"SUSE:Package Hub 15 SP1","fixed":["0.59.0-bp151.4.3.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-excon","purl":"pkg:rpm/suse/rubygem-excon\u0026distro=SUSE%20Package%20Hub%2015%20SP1","source":"openSUSE-SU-2020:0139-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["0.59.0-lp151.3.3.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-excon","purl":"pkg:rpm/opensuse/rubygem-excon\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2020:0036-1"}],"prev":{"headline":"Heap buffer overflow in `UnsortedSegmentSum` in TensorFlow","id":"CVE-2019-16778"},"products":["excon"],"published":"2019-12-16","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["excon"]},"summary":"A race condition in the excon Ruby library allows attackers to read leaked response data from previous requests via persistent connections.","url":"https://insights.sbomify.com/CVE-2019-16779/"}