# CVE-2019-16779: In RubyGem excon, interrupted Persistent Connections May Leak Response Data

> A race condition in the excon Ruby library allows attackers to read leaked response data from previous requests via persistent connections.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-16779, DLA-2070-1, GHSA-q58g-455p-8vw9, OESA-2021-1420, SUSE-SU-2020:2053-1, UBUNTU-CVE-2019-16779, openSUSE-SU-2020:0036-1, openSUSE-SU-2020:0139-1

## What is CVE-2019-16779?

CVE-2019-16779 is a medium-severity vulnerability in Debian Debian Linux, published on 16 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In RubyGem excon before 0.71.0, there was a race condition around persistent connections, where a connection which is interrupted (such as by a timeout) would leave data on the socket. Subsequent requests would then read this data, returning content from the previous response. The race condition window appears to be short, and it would be difficult to purposefully exploit this.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization), CWE-664 (Improper Control of a Resource Through its Lifetime)

## Which versions are affected by CVE-2019-16779?

2 open source packages ship an affected version, including excon. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `excon` | RubyGems | All versions | 0.71.0 |
| `excon` | RubyGems | All versions | 0.71.0 |
| `rubygem-excon` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 0.52.0-12.3.8 |
| `rubygem-excon` | SUSE:Package Hub 15 SP1 | All versions | 0.59.0-bp151.4.3.1 |
| `rubygem-excon` | openSUSE:Leap 15.1 | All versions | 0.59.0-lp151.3.3.1 |

Products: Debian Debian Linux, Excon Project Excon, Opensuse Backports Sle, Opensuse Leap.

## How do I fix CVE-2019-16779?

Upgrade excon to 0.71.0 or later.

## Is CVE-2019-16779 being exploited?

There is no known exploitation of CVE-2019-16779 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16779 and fix it if it is affected.

What it is: CVE-2019-16779 is a medium-severity vulnerability in Debian Debian Linux, published on 16 Dec 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-16779 in the wild and no public exploit code.

Affected packages and fixed versions:
- excon (RubyGems): affected all versions; fixed in 0.71.0
- excon (RubyGems): affected all versions; fixed in 0.71.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16779/ (Markdown: https://insights.sbomify.com/CVE-2019-16779/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16779
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16779
- OSV: https://osv.dev/vulnerability/CVE-2019-16779

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16779/
Summaries are generated and may contain mistakes; the official description above is the record.
