{"answers":{"affected":"3 open source packages ship an affected version, including waitress. It affects 5 products.","exploited":"There is no known exploitation of CVE-2019-16789 in the wild and no public exploit code.","fix":"Upgrade waitress to a fixed version for your release line: 1.4.1 or 1.4.2.","what":"CVE-2019-16789 is a high-severity vulnerability in Debian Debian Linux, published on 26 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-16789 and fix it if it is affected.\n\nWhat it is: CVE-2019-16789 is a high-severity vulnerability in Debian Debian Linux, published on 26 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-16789 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- waitress (PyPI): affected all versions; fixed in 1.4.1\n- waitress (PyPI): affected all versions; fixed in 1.4.2\n- waitress (PyPI): affected all versions; fixed in 1.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16789/ (Markdown: https://insights.sbomify.com/CVE-2019-16789/index.md)","id":"CVE-2019-16789","markdown":"https://insights.sbomify.com/CVE-2019-16789/index.md","name":"CVE-2019-16789","record":{"aliases":["DEBIAN-CVE-2019-16789","DLA-2056-1","GHSA-968f-66r5-5v74","PYSEC-2019-138","UBUNTU-CVE-2019-16789"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Python WSGI server","requires_auth":"low_privilege","summary":"Attackers can exploit HTTP request smuggling via invalid whitespace in headers when Waitress is behind a proxy, leading to cache poisoning or information disclosure.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"waitress","vendor":"agendaless"},{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"communications_cloud_native_core_network_function_cloud_native_environment","vendor":"oracle"},{"product":"openstack","vendor":"redhat"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"In Waitress through version 1.4.0, if a proxy server is used in front of waitress, an invalid request may be sent by an attacker that bypasses the front-end and is parsed differently by waitress leading to a potential for HTTP request smuggling. Specially crafted requests containing special whitespace characters in the Transfer-Encoding header would get parsed by Waitress as being a chunked request, but a front-end server would use the Content-Length instead as the Transfer-Encoding header is considered invalid due to containing invalid characters. If a front-end server does HTTP pipelining to a backend Waitress server this could lead to HTTP request splitting which may lead to potential cache poisoning or unexpected information disclosure. This issue is fixed in Waitress 1.4.1 through more strict HTTP field validation.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HTTP Request Smuggling in Waitress: Invalid whitespace characters in headers","id":"CVE-2019-16789","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","redhat:openstack"],"type":"other","year":"2019"},"n_packages":3,"n_references":8,"next":{"headline":"Remote Code Execution in Tiny File Manager","id":"CVE-2019-16790"},"packages":[{"ecosystem":"PyPI","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"waitress","purl":"pkg:pypi/waitress","source":"PYSEC-2019-138"},{"ecosystem":"PyPI","fixed":["1.4.2"],"introduced":["0"],"last_affected":[],"package":"waitress","purl":null,"source":"GHSA-968f-66r5-5v74"},{"ecosystem":"PyPI","fixed":["1.4.2"],"introduced":["0"],"last_affected":[],"package":"waitress","purl":"pkg:pypi/waitress","source":"GHSA-968f-66r5-5v74"}],"prev":{"headline":"HTTP Request Smuggling: Invalid Transfer-Encoding in Waitress","id":"CVE-2019-16786"},"products":["Waitress"],"published":"2019-12-26","related":[{"cvss_score":9.1,"headline":"Waitress has request processing race condition in HTTP pipelining with invalid first request","id":"CVE-2024-49768","kev_date_added":null,"published":"2024-10-29"},{"cvss_score":7.5,"headline":"Waitress has a denial of service leading to high CPU usage/resource exhaustion","id":"CVE-2024-49769","kev_date_added":null,"published":"2024-10-29"},{"cvss_score":7.5,"headline":"HTTP Request Smuggling in waitress","id":"CVE-2022-24761","kev_date_added":null,"published":"2022-03-17"},{"cvss_score":7.1,"headline":"HTTP Request Smuggling: Content-Length Sent Twice in Waitress","id":"CVE-2019-16792","kev_date_added":null,"published":"2020-01-22"},{"cvss_score":7.1,"headline":"HTTP Request Smuggling: LF vs CRLF handling in Waitress","id":"CVE-2019-16785","kev_date_added":null,"published":"2019-12-20"},{"cvss_score":7.1,"headline":"HTTP Request Smuggling: Invalid Transfer-Encoding in Waitress","id":"CVE-2019-16786","kev_date_added":null,"published":"2019-12-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Pylons"]},"summary":"Attackers can exploit HTTP request smuggling via invalid whitespace in headers when Waitress is behind a proxy, leading to cache poisoning or information disclosure.","url":"https://insights.sbomify.com/CVE-2019-16789/"}