# CVE-2019-16789: HTTP Request Smuggling in Waitress: Invalid whitespace characters in headers

> Attackers can exploit HTTP request smuggling via invalid whitespace in headers when Waitress is behind a proxy, leading to cache poisoning or information disclosure.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-16789, DLA-2056-1, GHSA-968f-66r5-5v74, PYSEC-2019-138, UBUNTU-CVE-2019-16789

## What is CVE-2019-16789?

CVE-2019-16789 is a high-severity vulnerability in Debian Debian Linux, published on 26 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Waitress through version 1.4.0, if a proxy server is used in front of waitress, an invalid request may be sent by an attacker that bypasses the front-end and is parsed differently by waitress leading to a potential for HTTP request smuggling. Specially crafted requests containing special whitespace characters in the Transfer-Encoding header would get parsed by Waitress as being a chunked request, but a front-end server would use the Content-Length instead as the Transfer-Encoding header is considered invalid due to containing invalid characters. If a front-end server does HTTP pipelining to a backend Waitress server this could lead to HTTP request splitting which may lead to potential cache poisoning or unexpected information disclosure. This issue is fixed in Waitress 1.4.1 through more strict HTTP field validation.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2019-16789?

3 open source packages ship an affected version, including waitress. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `waitress` | PyPI | All versions | 1.4.1 |
| `waitress` | PyPI | All versions | 1.4.2 |
| `waitress` | PyPI | All versions | 1.4.2 |

Products: Agendaless Waitress, Debian Debian Linux, Fedoraproject Fedora, Oracle Communications Cloud Native Core Network Function Cloud Native Environment, Redhat Openstack.

## How do I fix CVE-2019-16789?

Upgrade waitress to a fixed version for your release line: 1.4.1 or 1.4.2.

## Is CVE-2019-16789 being exploited?

There is no known exploitation of CVE-2019-16789 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2024-49768](https://insights.sbomify.com/CVE-2024-49768/): Waitress has request processing race condition in HTTP pipelining with invalid first request (critical 9.1)
- [CVE-2024-49769](https://insights.sbomify.com/CVE-2024-49769/): Waitress has a denial of service leading to high CPU usage/resource exhaustion (high 7.5)
- [CVE-2022-24761](https://insights.sbomify.com/CVE-2022-24761/): HTTP Request Smuggling in waitress (high 7.5)
- [CVE-2019-16792](https://insights.sbomify.com/CVE-2019-16792/): HTTP Request Smuggling: Content-Length Sent Twice in Waitress (high 7.1)
- [CVE-2019-16785](https://insights.sbomify.com/CVE-2019-16785/): HTTP Request Smuggling: LF vs CRLF handling in Waitress (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16789 and fix it if it is affected.

What it is: CVE-2019-16789 is a high-severity vulnerability in Debian Debian Linux, published on 26 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16789 in the wild and no public exploit code.

Affected packages and fixed versions:
- waitress (PyPI): affected all versions; fixed in 1.4.1
- waitress (PyPI): affected all versions; fixed in 1.4.2
- waitress (PyPI): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16789/ (Markdown: https://insights.sbomify.com/CVE-2019-16789/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16789
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16789
- OSV: https://osv.dev/vulnerability/CVE-2019-16789

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16789/
Summaries are generated and may contain mistakes; the official description above is the record.
