{"answers":{"affected":"3 open source packages ship an affected version, including postfix-mta-sts-resolver. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-16791 in the wild and no public exploit code.","fix":"Upgrade postfix-mta-sts-resolver to 0.5.1 or later.","what":"CVE-2019-16791 is a medium-severity vulnerability in Snawoot postfix-mta-sts-resolver, published on 22 Jan 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-16791 and fix it if it is affected.\n\nWhat it is: CVE-2019-16791 is a medium-severity vulnerability in Snawoot postfix-mta-sts-resolver, published on 22 Jan 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-16791 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postfix-mta-sts-resolver (PyPI): affected all versions; fixed in 0.5.1\n- postfix-mta-sts-resolver (PyPI): affected all versions; fixed in 0.5.1\n- postfix-mta-sts-resolver (PyPI): affected all versions; fixed in 0.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16791/ (Markdown: https://insights.sbomify.com/CVE-2019-16791/index.md)","id":"CVE-2019-16791","markdown":"https://insights.sbomify.com/CVE-2019-16791/index.md","name":"CVE-2019-16791","record":{"aliases":["GHSA-h92m-42h4-82f6","PYSEC-2020-174","UBUNTU-CVE-2019-16791"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Postfix MTA STS resolver","requires_auth":"high_privilege","summary":"An attacker can downgrade the effective Strict Transport Security policy in postfix-mta-sts-resolver, bypassing TLS enforcement protections.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"postfix-mta-sts-resolver","vendor":"postfix-mta-sts-resolver_project"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-757","name":"Selection of Less-Secure Algorithm During Negotiation"}],"description":"In postfix-mta-sts-resolver before 0.5.1, All users can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"downgrade of effective Strict Transport Security (STS) policy in postfix-mta-sts-resolver","id":"CVE-2019-16791","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2019"},"n_packages":3,"n_references":2,"next":{"headline":"HTTP Request Smuggling: Content-Length Sent Twice in Waitress","id":"CVE-2019-16792"},"packages":[{"ecosystem":"PyPI","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"postfix-mta-sts-resolver","purl":null,"source":"GHSA-h92m-42h4-82f6"},{"ecosystem":"PyPI","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"postfix-mta-sts-resolver","purl":"pkg:pypi/postfix-mta-sts-resolver","source":"GHSA-h92m-42h4-82f6"},{"ecosystem":"PyPI","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"postfix-mta-sts-resolver","purl":"pkg:pypi/postfix-mta-sts-resolver","source":"PYSEC-2020-174"}],"prev":{"headline":"Remote Code Execution in Tiny File Manager","id":"CVE-2019-16790"},"products":["postfix-mta-sts-resolver"],"published":"2020-01-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Snawoot"]},"summary":"An attacker can downgrade the effective Strict Transport Security policy in postfix-mta-sts-resolver, bypassing TLS enforcement protections.","url":"https://insights.sbomify.com/CVE-2019-16791/"}