# CVE-2019-16865: DOS attack in Pillow when processing specially crafted image files

> Attackers can cause denial of service in applications using Pillow by providing specially crafted invalid image files that trigger excessive memory allocation or processing time.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-16865, GHSA-j7mj-748x-7p78, PYSEC-2019-110, UBUNTU-CVE-2019-16865

## What is CVE-2019-16865?

CVE-2019-16865 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 4 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Pillow before 6.2.0. When reading specially crafted invalid image files, the library can either allocate very large amounts of memory or take an extremely long period of time to process the image.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2019-16865?

3 open source packages ship an affected version, including pillow. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | PyPI | All versions | 6.2.0 |
| `pillow` | PyPI | All versions | 6.2.0 |
| `pillow` | PyPI | All versions | 6.2.0 |

Products: Fedoraproject Fedora, Python Pillow.

## How do I fix CVE-2019-16865?

Upgrade pillow to 6.2.0 or later.

## Is CVE-2019-16865 being exploited?

There is no known exploitation of CVE-2019-16865 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16865 and fix it if it is affected.

What it is: CVE-2019-16865 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 4 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-16865 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (PyPI): affected all versions; fixed in 6.2.0
- pillow (PyPI): affected all versions; fixed in 6.2.0
- pillow (PyPI): affected all versions; fixed in 6.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16865/ (Markdown: https://insights.sbomify.com/CVE-2019-16865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16865
- OSV: https://osv.dev/vulnerability/CVE-2019-16865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16865/
Summaries are generated and may contain mistakes; the official description above is the record.
