CVE-2019-16943 jackson-databind polymorphic typing issue

Critical 9.8 Published Updated

Attackers can execute arbitrary code via deserialization in jackson-databind when Default Typing is enabled and p6spy is present.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-16943?

CVE-2019-16943 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 1 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A Polymorphic Typing issue was discovered in FasterXML jackson-databind 2.0.0 through 2.9.10. When Default Typing is enabled (either globally or for a specific property) for an externally exposed JSON endpoint and the service has the p6spy (3.8.6) jar in the classpath, and an attacker can find an RMI service endpoint to access, it is possible to make the service execute a malicious payload. This issue exists because of com.p6spy.engine.spy.P6DataSource mishandling.

Weakness: CWE-502

Which versions are affected by CVE-2019-16943?

6 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 26 products.

PackageAffectedFixed in
com.fasterxml.jackson.core:jackson-databind MavenAll versions2.6.7.3
com.fasterxml.jackson.core:jackson-databind MavenAll versions2.6.7.3
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.7.02.8.11.5
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.7.02.8.11.5
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.9.02.9.10.1
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.9.02.9.10.1

Products include Debian Debian Linux, Fasterxml Jackson-Databind, Fedoraproject Fedora, Netapp Active Iq Unified Manager, Netapp Oncommand Api Services, Netapp Oncommand Workflow Automation and 20 more.

How do I fix CVE-2019-16943?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.6.7.3, 2.8.11.5 or 2.9.10.1.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2019-16943 being exploited?

There is no known exploitation of CVE-2019-16943 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as CLEANSTART-2026-JD21089, DEBIAN-CVE-2019-16943, GHSA-fmmc-742q-jg75, ROOT-APP-MAVEN-CVE-2019-16943, UBUNTU-CVE-2019-16943.

Is CVE-2019-16943 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free