{"answers":{"affected":"2 open source packages ship an affected version, including phpbb/phpbb. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-16993 in the wild and no public exploit code.","fix":"Upgrade phpbb/phpbb to 3.1.7-PL1 or later.","what":"CVE-2019-16993 is a high-severity vulnerability in Debian Debian Linux, published on 30 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-16993 and fix it if it is affected.\n\nWhat it is: CVE-2019-16993 is a high-severity vulnerability in Debian Debian Linux, published on 30 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-16993 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpbb/phpbb (Packagist): affected all versions; fixed in 3.1.7-PL1\n- phpbb/phpbb (Packagist): affected all versions; fixed in 3.1.7-PL1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-16993/ (Markdown: https://insights.sbomify.com/CVE-2019-16993/index.md)","id":"CVE-2019-16993","markdown":"https://insights.sbomify.com/CVE-2019-16993/index.md","name":"CVE-2019-16993","record":{"aliases":["GHSA-vj3x-vfm4-hvxc","UBUNTU-CVE-2019-16993"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"phpBB forum software","requires_auth":"none","summary":"Attackers can perform CSRF attacks on the BBCode admin page if they steal an administrator's session ID, potentially leading to unauthorized administrative actions.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"phpbb","vendor":"phpbb"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a CSRF token on the BBCode page in the Administration Control Panel. An actual CSRF attack is possible if an attacker also manages to retrieve the session id of a reauthenticated administrator prior to targeting them.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpBB Cross-Site Request Forgery (CSRF)","id":"CVE-2019-16993","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"csrf","year":"2019"},"n_packages":2,"n_references":5,"next":{"headline":"Denial of service in n/a","id":"CVE-2019-16994"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.7-PL1"],"introduced":["0"],"last_affected":[],"package":"phpbb/phpbb","purl":null,"source":"GHSA-vj3x-vfm4-hvxc"},{"ecosystem":"Packagist","fixed":["3.1.7-PL1"],"introduced":["0"],"last_affected":[],"package":"phpbb/phpbb","purl":"pkg:composer/phpbb/phpbb","source":"GHSA-vj3x-vfm4-hvxc"}],"prev":{"headline":"Other in n/a","id":"CVE-2019-16992"},"products":["n/a"],"published":"2019-09-30","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can perform CSRF attacks on the BBCode admin page if they steal an administrator's session ID, potentially leading to unauthorized administrative actions.","url":"https://insights.sbomify.com/CVE-2019-16993/"}