# CVE-2019-16993: phpBB Cross-Site Request Forgery (CSRF)

> Attackers can perform CSRF attacks on the BBCode admin page if they steal an administrator's session ID, potentially leading to unauthorized administrative actions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Sep 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vj3x-vfm4-hvxc, UBUNTU-CVE-2019-16993

## What is CVE-2019-16993?

CVE-2019-16993 is a high-severity vulnerability in Debian Debian Linux, published on 30 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a CSRF token on the BBCode page in the Administration Control Panel. An actual CSRF attack is possible if an attacker also manages to retrieve the session id of a reauthenticated administrator prior to targeting them.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-16993?

2 open source packages ship an affected version, including phpbb/phpbb. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpbb/phpbb` | Packagist | All versions | 3.1.7-PL1 |
| `phpbb/phpbb` | Packagist | All versions | 3.1.7-PL1 |

Products: Debian Debian Linux, Phpbb Phpbb.

## How do I fix CVE-2019-16993?

Upgrade phpbb/phpbb to 3.1.7-PL1 or later.

## Is CVE-2019-16993 being exploited?

There is no known exploitation of CVE-2019-16993 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-16993 and fix it if it is affected.

What it is: CVE-2019-16993 is a high-severity vulnerability in Debian Debian Linux, published on 30 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-16993 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpbb/phpbb (Packagist): affected all versions; fixed in 3.1.7-PL1
- phpbb/phpbb (Packagist): affected all versions; fixed in 3.1.7-PL1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-16993/ (Markdown: https://insights.sbomify.com/CVE-2019-16993/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-16993
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-16993
- OSV: https://osv.dev/vulnerability/CVE-2019-16993

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-16993/
Summaries are generated and may contain mistakes; the official description above is the record.
