{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-17113 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-17113 is a critical memory corruption vulnerability in n/a, published on 3 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-17113 and fix it if it is affected.\n\nWhat it is: CVE-2019-17113 is a critical memory corruption vulnerability in n/a, published on 3 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-17113 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-17113/ (Markdown: https://insights.sbomify.com/CVE-2019-17113/index.md)","id":"CVE-2019-17113","markdown":"https://insights.sbomify.com/CVE-2019-17113/index.md","name":"CVE-2019-17113","record":{"aliases":["DEBIAN-CVE-2019-17113","DLA-2308-1","GHSA-9qmp-r7mf-m39c","SUSE-SU-2019:2622-1","UBUNTU-CVE-2019-17113","USN-8206-1","openSUSE-SU-2019:2306-1","openSUSE-SU-2019:2319-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"libopenmpt audio library","requires_auth":"none","summary":"A buffer overflow in libopenmpt's C API allows attackers to execute arbitrary code or cause denial of service via crafted audio files.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libopenmpt","vendor":"openmpt"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName in libopenmpt_modplug.c do not restrict the lengths of libmodplug output-buffer strings in the C API, leading to a buffer overflow.","ecosystems":["SUSE:Linux Enterprise Module for Desktop Applications 15","SUSE:Linux Enterprise Module for Desktop Applications 15 SP1","openSUSE:Leap 15.0","openSUSE:Leap 15.1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2019-17113","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2019"},"n_packages":4,"n_references":8,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-17114"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15","fixed":["0.3.19-2.10.1"],"introduced":["0"],"last_affected":[],"package":"libopenmpt","purl":"pkg:rpm/suse/libopenmpt\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015","source":"SUSE-SU-2019:2622-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP1","fixed":["0.3.19-2.10.1"],"introduced":["0"],"last_affected":[],"package":"libopenmpt","purl":"pkg:rpm/suse/libopenmpt\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP1","source":"SUSE-SU-2019:2622-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["0.3.19-lp150.10.1"],"introduced":["0"],"last_affected":[],"package":"libopenmpt","purl":"pkg:rpm/opensuse/libopenmpt\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:2319-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["0.3.19-lp151.2.6.1"],"introduced":["0"],"last_affected":[],"package":"libopenmpt","purl":"pkg:rpm/opensuse/libopenmpt\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2019:2306-1"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2019-17112"},"products":["n/a"],"published":"2019-10-03","related":[{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2018-11710","kev_date_added":null,"published":"2018-06-04"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2018-6611","kev_date_added":null,"published":"2018-02-04"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2017-11311","kev_date_added":null,"published":"2017-07-13"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2019-14381","kev_date_added":null,"published":"2019-07-30"},{"cvss_score":6.5,"headline":"Denial of service in n/a","id":"CVE-2018-20860","kev_date_added":null,"published":"2019-07-30"},{"cvss_score":6.5,"headline":"Denial of service in n/a","id":"CVE-2018-20861","kev_date_added":null,"published":"2019-07-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A buffer overflow in libopenmpt's C API allows attackers to execute arbitrary code or cause denial of service via crafted audio files.","url":"https://insights.sbomify.com/CVE-2019-17113/"}