# CVE-2019-17268: omniauth-weibo-oauth2 included a code-execution backdoor inserted by a third party

> A backdoor in the omniauth-weibo-oauth2 gem allows attackers to execute arbitrary code via malicious package distribution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vr22-43gj-rx3f

## What is CVE-2019-17268?

CVE-2019-17268 is a critical code injection vulnerability in n/a, published on 7 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The omniauth-weibo-oauth2 gem 0.4.6 for Ruby, as distributed on RubyGems.org, included a code-execution backdoor inserted by a third party. Versions through 0.4.5, and 0.5.1 and later, are unaffected.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2019-17268?

2 open source packages ship an affected version, including omniauth-weibo-oauth2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `omniauth-weibo-oauth2` | RubyGems | From 0.4.6 | 0.5.1 |
| `omniauth-weibo-oauth2` | RubyGems | From 0.4.6 | 0.5.1 |

Products: Omniauth-Weibo-Oauth2 Project Omniauth-Weibo-Oauth2.

## How do I fix CVE-2019-17268?

Upgrade omniauth-weibo-oauth2 to 0.5.1 or later.

## Is CVE-2019-17268 being exploited?

There is no known exploitation of CVE-2019-17268 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-17268 and fix it if it is affected.

What it is: CVE-2019-17268 is a critical code injection vulnerability in n/a, published on 7 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-17268 in the wild and no public exploit code.

Affected packages and fixed versions:
- omniauth-weibo-oauth2 (RubyGems): affected from 0.4.6; fixed in 0.5.1
- omniauth-weibo-oauth2 (RubyGems): affected from 0.4.6; fixed in 0.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-17268/ (Markdown: https://insights.sbomify.com/CVE-2019-17268/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-17268
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-17268
- OSV: https://osv.dev/vulnerability/CVE-2019-17268

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-17268/
Summaries are generated and may contain mistakes; the official description above is the record.
