# CVE-2019-17361: SaltStack Salt is vulnerable to command injection

> Unauthenticated attackers can execute arbitrary code on the Salt API host via command injection in the NET API when the ssh client is enabled.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jan 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-q53j-p6r2-g2v4, PYSEC-2020-177, SUSE-SU-2020:0538-1, SUSE-SU-2020:0540-1, UBUNTU-CVE-2019-17361

## What is CVE-2019-17361?

CVE-2019-17361 is a critical command injection vulnerability in Canonical Ubuntu Linux, published on 17 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In SaltStack Salt through 2019.2.0, the salt-api NET API with the ssh client enabled is vulnerable to command injection. This allows an unauthenticated attacker with network access to the API endpoint to execute arbitrary code on the salt-api host.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2019-17361?

3 open source packages ship an affected version, including salt. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `salt` | PyPI | All versions | 2019.2.1 |
| `salt` | PyPI | All versions | 2019.2.3 |
| `salt` | PyPI | All versions | 2019.2.3 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Opensuse Leap, Saltstack Salt.

## How do I fix CVE-2019-17361?

Upgrade salt to a fixed version for your release line: 2019.2.1 or 2019.2.3.

## Is CVE-2019-17361 being exploited?

There is no known exploitation of CVE-2019-17361 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-17361 and fix it if it is affected.

What it is: CVE-2019-17361 is a critical command injection vulnerability in Canonical Ubuntu Linux, published on 17 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-17361 in the wild and no public exploit code.

Affected packages and fixed versions:
- salt (PyPI): affected all versions; fixed in 2019.2.1
- salt (PyPI): affected all versions; fixed in 2019.2.3
- salt (PyPI): affected all versions; fixed in 2019.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-17361/ (Markdown: https://insights.sbomify.com/CVE-2019-17361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-17361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-17361
- OSV: https://osv.dev/vulnerability/CVE-2019-17361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-17361/
Summaries are generated and may contain mistakes; the official description above is the record.
