CVE-2019-17383 netaddr before 1.5.3 and 2.0.4 has Incorrect Default Permissions
The netaddr Ruby gem installs with world-writable permissions, allowing local attackers to modify files and potentially escalate privileges.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-17383?
CVE-2019-17383 is a critical vulnerability in n/a, published on 9 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The netaddr gem before 2.0.4 for Ruby has misconfigured file permissions, such that a gem install may result in 0777 permissions in the target filesystem.
Weakness: CWE-276
Which versions are affected by CVE-2019-17383?
4 open source packages ship an affected version, including netaddr. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
netaddr RubyGems | All versions | 1.5.3 |
netaddr RubyGems | All versions | 1.5.3 |
netaddr RubyGems | From 2.0.0 | 2.0.4 |
netaddr RubyGems | From 2.0.0 | 2.0.4 |
Products include Netaddr Project Netaddr.
How do I fix CVE-2019-17383?
Upgrade netaddr to a fixed version for your release line: 1.5.3 or 2.0.4.
Is CVE-2019-17383 being exploited?
There is no known exploitation of CVE-2019-17383 in the wild and no public exploit code.
Sources
Also known as GHSA-49pj-69vf-c689, UBUNTU-CVE-2019-17383.