# CVE-2019-17383: netaddr before 1.5.3 and 2.0.4 has Incorrect Default Permissions

> The netaddr Ruby gem installs with world-writable permissions, allowing local attackers to modify files and potentially escalate privileges.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-49pj-69vf-c689, UBUNTU-CVE-2019-17383

## What is CVE-2019-17383?

CVE-2019-17383 is a critical vulnerability in n/a, published on 9 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The netaddr gem before 2.0.4 for Ruby has misconfigured file permissions, such that a gem install may result in 0777 permissions in the target filesystem.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2019-17383?

4 open source packages ship an affected version, including netaddr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `netaddr` | RubyGems | All versions | 1.5.3 |
| `netaddr` | RubyGems | All versions | 1.5.3 |
| `netaddr` | RubyGems | From 2.0.0 | 2.0.4 |
| `netaddr` | RubyGems | From 2.0.0 | 2.0.4 |

Products: Netaddr Project Netaddr.

## How do I fix CVE-2019-17383?

Upgrade netaddr to a fixed version for your release line: 1.5.3 or 2.0.4.

## Is CVE-2019-17383 being exploited?

There is no known exploitation of CVE-2019-17383 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-17383 and fix it if it is affected.

What it is: CVE-2019-17383 is a critical vulnerability in n/a, published on 9 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-17383 in the wild and no public exploit code.

Affected packages and fixed versions:
- netaddr (RubyGems): affected all versions; fixed in 1.5.3
- netaddr (RubyGems): affected all versions; fixed in 1.5.3
- netaddr (RubyGems): affected from 2.0.0; fixed in 2.0.4
- netaddr (RubyGems): affected from 2.0.0; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-17383/ (Markdown: https://insights.sbomify.com/CVE-2019-17383/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-17383
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-17383
- OSV: https://osv.dev/vulnerability/CVE-2019-17383

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-17383/
Summaries are generated and may contain mistakes; the official description above is the record.
