# CVE-2019-17400: Server-Side Request Forgery in unoconv

> Attackers can exploit untrusted pathnames in unoconv to perform Server-Side Request Forgery and read local files.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-17400, GHSA-27p5-7cw6-m45h, PYSEC-2019-213, RHSA-2020:3944, UBUNTU-CVE-2019-17400

## What is CVE-2019-17400?

CVE-2019-17400 is a high-severity server-side request forgery vulnerability in n/a, published on 21 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The unoconv package before 0.9 mishandles untrusted pathnames, leading to SSRF and local file inclusion.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2019-17400?

3 open source packages ship an affected version, including unoconv. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `unoconv` | PyPI | All versions | 0.9.0 |
| `unoconv` | PyPI | All versions | 0.9.0 |
| `unoconv` | PyPI | All versions | 0.9.0 |
| `unoconv` | Red Hat:enterprise_linux:7::client | All versions | 0:0.6-8.el7 |
| `unoconv` | Red Hat:enterprise_linux:7::server | All versions | 0:0.6-8.el7 |
| `unoconv` | Red Hat:enterprise_linux:7::workstation | All versions | 0:0.6-8.el7 |

Products: Universal Office Converter Project Universal Office Converter.

## How do I fix CVE-2019-17400?

Upgrade unoconv to 0.9.0 or later.

## Is CVE-2019-17400 being exploited?

There is no known exploitation of CVE-2019-17400 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-17400 and fix it if it is affected.

What it is: CVE-2019-17400 is a high-severity server-side request forgery vulnerability in n/a, published on 21 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-17400 in the wild and no public exploit code.

Affected packages and fixed versions:
- unoconv (PyPI): affected all versions; fixed in 0.9.0
- unoconv (PyPI): affected all versions; fixed in 0.9.0
- unoconv (PyPI): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-17400/ (Markdown: https://insights.sbomify.com/CVE-2019-17400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-17400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-17400
- OSV: https://osv.dev/vulnerability/CVE-2019-17400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-17400/
Summaries are generated and may contain mistakes; the official description above is the record.
