CVE-2019-17426 Improper Input Validation in Automattic Mongoose

Critical 9.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2019-17426?

CVE-2019-17426 is a critical vulnerability in n/a, published on 10 Oct 2019.

Official description

Automattic Mongoose through 5.7.4 allows attackers to bypass access control (in some applications) because any query object with a _bsontype attribute is ignored. For example, adding "_bsontype":"a" can sometimes interfere with a query filter. NOTE: this CVE is about Mongoose's failure to work around this _bsontype special case that exists in older versions of the bson parser (aka the mongodb/js-bson project).

Which versions are affected by CVE-2019-17426?

4 open source packages ship an affected version, including mongoose. It affects 1 product.

PackageAffectedFixed in
mongoose npmAll versions4.13.21
mongoose npmAll versions4.13.21
mongoose npmFrom 5.0.05.7.5
mongoose npmFrom 5.0.05.7.5

Products include Mongoosejs Mongoose.

How do I fix CVE-2019-17426?

Upgrade mongoose to a fixed version for your release line: 4.13.21 or 5.7.5.

Is CVE-2019-17426 being exploited?

There is no known exploitation of CVE-2019-17426 in the wild and no public exploit code.

Sources

Also known as GHSA-8687-vv9j-hgph.

Is CVE-2019-17426 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free