CVE-2019-17531 jackson-databind polymorphic typing issue
Attackers can execute arbitrary code via JNDI injection if Default Typing is enabled and log4j-extra is present.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-17531?
CVE-2019-17531 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 12 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A Polymorphic Typing issue was discovered in FasterXML jackson-databind 2.0.0 through 2.9.10. When Default Typing is enabled (either globally or for a specific property) for an externally exposed JSON endpoint and the service has the apache-log4j-extra (version 1.2.x) jar in the classpath, and an attacker can provide a JNDI service to access, it is possible to make the service execute a malicious payload.
Weakness: CWE-502
Which versions are affected by CVE-2019-17531?
6 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 22 products.
| Package | Affected | Fixed in |
|---|---|---|
com.fasterxml.jackson.core:jackson-databind Maven | All versions | 2.6.7.3 |
com.fasterxml.jackson.core:jackson-databind Maven | All versions | 2.6.7.3 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.7.0 | 2.8.11.5 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.7.0 | 2.8.11.5 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.10.1 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.10.1 |
Linux distribution packages (2)
rh-maven35-jackson-databind Red Hat:rhel_software_collections:3::el7 | All versions | 0:2.7.6-2.8.el7 |
rh-maven35-jackson-databind-javadoc Red Hat:rhel_software_collections:3::el7 | All versions | 0:2.7.6-2.8.el7 |
Products include Debian Debian Linux, Fasterxml Jackson-Databind, Netapp Oncommand Workflow Automation, Netapp Steelstore Cloud Integrated Storage, Oracle Banking Platform, Oracle Communications Billing and Revenue Management and 16 more.
How do I fix CVE-2019-17531?
Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.6.7.3, 2.8.11.5 or 2.9.10.1.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2019-17531 being exploited?
There is no known exploitation of CVE-2019-17531 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-TS69470, DEBIAN-CVE-2019-17531, GHSA-gjmw-vf9h-g25v, OESA-2022-1782, RHSA-2019:4192, ROOT-APP-MAVEN-CVE-2019-17531 and 1 more.