# CVE-2019-17545: Use after free in n/a

> A double free vulnerability in GDAL's OGRExpatRealloc function allows attackers to cause denial of service or potentially execute code via crafted data exceeding 10MB.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-17545, DLA-1984-1, GHSA-f6m2-5v5j-rhf2, MGASA-2020-0068, PYSEC-2019-241, UBUNTU-CVE-2019-17545, openSUSE-SU-2019:2466-1

## What is CVE-2019-17545?

CVE-2019-17545 is a critical use after free vulnerability in Debian Debian Linux, published on 14 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GDAL through 3.0.1 has a poolDestroy double free in OGRExpatRealloc in ogr/ogr_expat.cpp when the 10MB threshold is exceeded.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2019-17545?

1 open source package ship an affected version, including gdal. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gdal` | PyPI | All versions | 3.0.2 |
| `gdal` | SUSE:Package Hub 15 SP1 | All versions | 2.4.3-bp151.4.3.1 |
| `gdal` | openSUSE:Leap 15.1 | All versions | 2.4.3-bp151.4.3.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Opensuse Backports Sle, Opensuse Leap, Oracle Spatial and Graph, Osgeo Gdal.

## How do I fix CVE-2019-17545?

Upgrade gdal to 3.0.2 or later.

## Is CVE-2019-17545 being exploited?

There is no known exploitation of CVE-2019-17545 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-17545 and fix it if it is affected.

What it is: CVE-2019-17545 is a critical use after free vulnerability in Debian Debian Linux, published on 14 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-17545 in the wild and no public exploit code.

Affected packages and fixed versions:
- gdal (PyPI): affected all versions; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-17545/ (Markdown: https://insights.sbomify.com/CVE-2019-17545/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-17545
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-17545
- OSV: https://osv.dev/vulnerability/CVE-2019-17545

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-17545/
Summaries are generated and may contain mistakes; the official description above is the record.
