# CVE-2019-17555: Improper input validation in Apache Olingo

> A malicious server can cause a denial of service in Apache Olingo by sending a large Retry-After header value that triggers an excessive thread sleep.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Dec 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-477x-w7m6-c6ph

## What is CVE-2019-17555?

CVE-2019-17555 is a high-severity denial of service vulnerability in Apache Olingo, published on 4 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The AsyncResponseWrapperImpl class in Apache Olingo versions 4.0.0 to 4.6.0 reads the Retry-After header and passes it to the Thread.sleep() method without any check. If a malicious server returns a huge value in the header, then it can help to implement a DoS attack.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2019-17555?

2 open source packages ship an affected version, including org.apache.olingo:odata-client-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.olingo:odata-client-core` | Maven | From 4.0.0 | 4.7.0 |
| `org.apache.olingo:odata-client-core` | Maven | From 4.0.0 | 4.7.0 |

Products: Apache Olingo.

## How do I fix CVE-2019-17555?

Upgrade org.apache.olingo:odata-client-core to 4.7.0 or later.

## Is CVE-2019-17555 being exploited?

There is no known exploitation of CVE-2019-17555 in the wild and no public exploit code.

## Other vulnerabilities in Apache Olingo

- [CVE-2019-17556](https://insights.sbomify.com/CVE-2019-17556/): Deserialization of Untrusted Data in Apache Olingo (critical 9.8)
- [CVE-2020-1925](https://insights.sbomify.com/CVE-2020-1925/): Server-Side Request Forgery (SSRF) in Apache Olingo (high 7.5)
- [CVE-2019-17554](https://insights.sbomify.com/CVE-2019-17554/): Improper Restriction of XML External Entity Reference in Apache Olingo (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-17555 and fix it if it is affected.

What it is: CVE-2019-17555 is a high-severity denial of service vulnerability in Apache Olingo, published on 4 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-17555 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.olingo:odata-client-core (Maven): affected from 4.0.0; fixed in 4.7.0
- org.apache.olingo:odata-client-core (Maven): affected from 4.0.0; fixed in 4.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-17555/ (Markdown: https://insights.sbomify.com/CVE-2019-17555/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-17555
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-17555
- OSV: https://osv.dev/vulnerability/CVE-2019-17555

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-17555/
Summaries are generated and may contain mistakes; the official description above is the record.
