# CVE-2019-17592: Regular Expression Denial of Service in csv-parse

> An attacker can cause a denial of service in applications using the csv-parse library by providing crafted input when the cast option is enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-582f-p4pg-xc74

## What is CVE-2019-17592?

CVE-2019-17592 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 14 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The csv-parse module before 4.4.6 for Node.js is vulnerable to Regular Expression Denial of Service. The __isInt() function contains a malformed regular expression that processes large crafted input very slowly. This is triggered when using the cast option.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2019-17592?

2 open source packages ship an affected version, including csv-parse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `csv-parse` | npm | All versions | 4.4.6 |
| `csv-parse` | npm | All versions | 4.4.6 |

Products: Csv-Parse Project Csv-Parse, Fedoraproject Fedora.

## How do I fix CVE-2019-17592?

Upgrade csv-parse to 4.4.6 or later.

## Is CVE-2019-17592 being exploited?

There is no known exploitation of CVE-2019-17592 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-17592 and fix it if it is affected.

What it is: CVE-2019-17592 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 14 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-17592 in the wild and no public exploit code.

Affected packages and fixed versions:
- csv-parse (npm): affected all versions; fixed in 4.4.6
- csv-parse (npm): affected all versions; fixed in 4.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-17592/ (Markdown: https://insights.sbomify.com/CVE-2019-17592/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-17592
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-17592
- OSV: https://osv.dev/vulnerability/CVE-2019-17592

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-17592/
Summaries are generated and may contain mistakes; the official description above is the record.
