# CVE-2019-17596: Denial of service in n/a

> An attacker can cause a denial of service by sending invalid DSA public keys in network traffic to Go applications verifying client certificates.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** AZL-79090, AZL-98898, CLEANSTART-2025-KH04903, DSA-4551-1, GHSA-gcr4-wcqh-3624, GO-2022-0213, MGASA-2019-0310, UBUNTU-CVE-2019-17596

## What is CVE-2019-17596?

CVE-2019-17596 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 24 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Go before 1.12.11 and 1.3.x before 1.13.2 can panic upon an attempt to process network traffic containing an invalid DSA public key. There are several attack scenarios, such as traffic from a client to a server that verifies client certificates.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2019-17596?

1 open source package ship an affected version, including stdlib. It affects 11 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stdlib` | Go | All versions | 1.12.11, 1.13.2 |

Products: Arista Cloudvision Portal, Arista Eos, Arista Mos, Arista Terminattr, Debian Debian Linux, Fedoraproject Fedora, Golang Go, Opensuse Leap, Redhat Developer Tools, Redhat Enterprise Linux, Redhat Enterprise Linux Server.

## How do I fix CVE-2019-17596?

Upgrade stdlib to a fixed version for your release line: 1.12.11 or 1.13.2.

## Is CVE-2019-17596 being exploited?

There is no known exploitation of CVE-2019-17596 in the wild and no public exploit code.

Public exploit code:

- Demonstration of Go's dsa.Verify bug (CVE-2019-17596) (github_poc): https://github.com/pquerna/poc-dsa-verify-CVE-2019-17596

## Other vulnerabilities in Debian Debian Linux

- [CVE-2016-9012](https://insights.sbomify.com/CVE-2016-9012/): Missing authorization in n/a (high 8.8)
- [CVE-2023-24546](https://insights.sbomify.com/CVE-2023-24546/): Missing authorization in CloudVision (high 8.1)
- [CVE-2019-18181](https://insights.sbomify.com/CVE-2019-18181/): Missing authorization in n/a (high 7.8)
- [CVE-2020-13881](https://insights.sbomify.com/CVE-2020-13881/): Information disclosure in n/a (high 7.5)
- [CVE-2020-24333](https://insights.sbomify.com/CVE-2020-24333/): Path traversal in n/a (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-17596 and fix it if it is affected.

What it is: CVE-2019-17596 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 24 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-17596 in the wild and no public exploit code.

Affected packages and fixed versions:
- stdlib (Go): affected all versions; fixed in 1.12.11, 1.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-17596/ (Markdown: https://insights.sbomify.com/CVE-2019-17596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-17596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-17596
- OSV: https://osv.dev/vulnerability/CVE-2019-17596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-17596/
Summaries are generated and may contain mistakes; the official description above is the record.
