# CVE-2019-17632: Unescaped exception messages in error responses in Jetty

> Attackers can inject malicious scripts via unescaped exception messages in default error responses, potentially leading to cross-site scripting attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-17632, GHSA-5h9j-q6j2-253f, UBUNTU-CVE-2019-17632

## What is CVE-2019-17632?

CVE-2019-17632 is a medium-severity cross-site scripting vulnerability in Eclipse Jetty, published on 25 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Eclipse Jetty versions 9.4.21.v20190926, 9.4.22.v20191022, and 9.4.23.v20191118, the generation of default unhandled Error response content (in text/html and text/json Content-Type) does not escape Exception messages in stacktraces included in error output.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-17632?

6 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.21.v20190926 | 9.4.24.v20191120 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.21.v20190926 | 9.4.24.v20191120 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.22.v20191022 | 9.4.24.v20191120 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.22.v20191022 | 9.4.24.v20191120 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.23.v20191118 | 9.4.24.v20191120 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.23.v20191118 | 9.4.24.v20191120 |

Products: Eclipse Jetty.

## How do I fix CVE-2019-17632?

Upgrade org.eclipse.jetty:jetty-server to 9.4.24.v20191120 or later.

## Is CVE-2019-17632 being exploited?

There is no known exploitation of CVE-2019-17632 in the wild and no public exploit code.

## Other vulnerabilities in Eclipse Jetty

- [CVE-2016-4800](https://insights.sbomify.com/CVE-2016-4800/): Jetty contains an alias issue that could allow unauthenticated remote code execution due to specially crafted request (critical 9.8)
- [CVE-2019-17638](https://insights.sbomify.com/CVE-2019-17638/): Operation on a Resource after Expiration or Release in Jetty Server (critical 9.4)
- [CVE-2018-12538](https://insights.sbomify.com/CVE-2018-12538/): Access and integrity issue within Eclipse Jetty (high 8.8)
- [CVE-2026-10050](https://insights.sbomify.com/CVE-2026-10050/): Digest authentication lossy encoding (high 8.7)
- [CVE-2025-5115](https://insights.sbomify.com/CVE-2025-5115/): MadeYouReset HTTP/2 vulnerability (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-17632 and fix it if it is affected.

What it is: CVE-2019-17632 is a medium-severity cross-site scripting vulnerability in Eclipse Jetty, published on 25 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-17632 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.21.v20190926; fixed in 9.4.24.v20191120
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.21.v20190926; fixed in 9.4.24.v20191120
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.22.v20191022; fixed in 9.4.24.v20191120
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.22.v20191022; fixed in 9.4.24.v20191120
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.23.v20191118; fixed in 9.4.24.v20191120
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.23.v20191118; fixed in 9.4.24.v20191120

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-17632/ (Markdown: https://insights.sbomify.com/CVE-2019-17632/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-17632
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-17632
- OSV: https://osv.dev/vulnerability/CVE-2019-17632

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-17632/
Summaries are generated and may contain mistakes; the official description above is the record.
