# CVE-2019-17636: Insufficient Verification of Data Authenticity in Eclipse Theia

> Remote attackers can read arbitrary host files via the Mini-Browser extension's unrestricted HTTP endpoint using DNS rebinding or drive-by downloads.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Mar 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-f7vx-j8mp-3h2x

## What is CVE-2019-17636?

CVE-2019-17636 is a high-severity path traversal vulnerability in Eclipse Theia, published on 10 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Eclipse Theia versions 0.3.9 through 0.15.0, one of the default pre-packaged Theia extensions is "Mini-Browser", published as "@theia/mini-browser" on npmjs.com. This extension, for its own needs, exposes a HTTP endpoint that allows to read the content of files on the host's filesystem, given their path, without restrictions on the requester's origin. This design is vulnerable to being exploited remotely through a DNS rebinding attack or a drive-by download of a carefully crafted exploit.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2019-17636?

2 open source packages ship an affected version, including @theia/mini-browser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@theia/mini-browser` | npm | From 0.3.9 | 0.16.0 |
| `@theia/mini-browser` | npm | From 0.3.9 | 0.16.0 |

Products: Eclipse Theia.

## How do I fix CVE-2019-17636?

Upgrade @theia/mini-browser to 0.16.0 or later.

## Is CVE-2019-17636 being exploited?

There is no known exploitation of CVE-2019-17636 in the wild and no public exploit code.

## Other vulnerabilities in Eclipse Theia

- [CVE-2021-34436](https://insights.sbomify.com/CVE-2021-34436/): XML external entity in Eclipse Theia (critical 9.8)
- [CVE-2020-27224](https://insights.sbomify.com/CVE-2020-27224/): Cross-site Scripting (XSS) in Eclipse Theia (critical 9.6)
- [CVE-2026-60009](https://insights.sbomify.com/CVE-2026-60009/): File upload in Eclipse Theia (high 8.8)
- [CVE-2021-34435](https://insights.sbomify.com/CVE-2021-34435/): Remote code execution in Eclipse Theia (high 8.8)
- [CVE-2026-44688](https://insights.sbomify.com/CVE-2026-44688/): [Eclipse Theia] Indirect Prompt Injection via Adversarial Workspace File and Directory Names in AI Chat (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-17636 and fix it if it is affected.

What it is: CVE-2019-17636 is a high-severity path traversal vulnerability in Eclipse Theia, published on 10 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-17636 in the wild and no public exploit code.

Affected packages and fixed versions:
- @theia/mini-browser (npm): affected from 0.3.9; fixed in 0.16.0
- @theia/mini-browser (npm): affected from 0.3.9; fixed in 0.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-17636/ (Markdown: https://insights.sbomify.com/CVE-2019-17636/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-17636
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-17636
- OSV: https://osv.dev/vulnerability/CVE-2019-17636

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-17636/
Summaries are generated and may contain mistakes; the official description above is the record.
