# CVE-2019-17638: Operation on a Resource after Expiration or Release in Jetty Server

> A race condition in Eclipse Jetty allows attackers to view sensitive data from other users' requests due to double-release of response buffers.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2020
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-17638, GHSA-x3rh-m7vp-35f2

## What is CVE-2019-17638?

CVE-2019-17638 is a critical vulnerability in Eclipse Jetty, published on 9 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Eclipse Jetty, versions 9.4.27.v20200227 to 9.4.29.v20200521, in case of too large response headers, Jetty throws an exception to produce an HTTP 431 error. When this happens, the ByteBuffer containing the HTTP response headers is released back to the ByteBufferPool twice. Because of this double release, two threads can acquire the same ByteBuffer from the pool and while thread1 is about to use the ByteBuffer to write response1 data, thread2 fills the ByteBuffer with other data. Thread1 then proceeds to write the buffer that now contains different data. This results in client1, which issued request1 seeing data from another request or response which could contain sensitive data belonging to client2 (HTTP session ids, authentication credentials, etc.). If the Jetty version cannot be upgraded, the vulnerability can be significantly reduced by configuring a responseHeaderSize significantly larger than the requestHeaderSize (12KB responseHeaderSize and 8KB requestHeaderSize).

Weakness: CWE-675 (Multiple Operations on Resource in Single-Operation Context), CWE-672 (Operation on a Resource after Expiration or Release)

## Which versions are affected by CVE-2019-17638?

2 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.27 | 9.4.30.v20200611 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.27 | 9.4.30.v20200611 |

Products: Eclipse Jetty.

## How do I fix CVE-2019-17638?

Upgrade org.eclipse.jetty:jetty-server to 9.4.30.v20200611 or later.

## Is CVE-2019-17638 being exploited?

There is no known exploitation of CVE-2019-17638 in the wild and no public exploit code.

Public exploit code:

- https://github.com/forse01/CVE-2019-17638-Jetty (github_poc): https://github.com/forse01/CVE-2019-17638-Jetty

## Other vulnerabilities in Eclipse Jetty

- [CVE-2016-4800](https://insights.sbomify.com/CVE-2016-4800/): Jetty contains an alias issue that could allow unauthenticated remote code execution due to specially crafted request (critical 9.8)
- [CVE-2018-12538](https://insights.sbomify.com/CVE-2018-12538/): Access and integrity issue within Eclipse Jetty (high 8.8)
- [CVE-2026-10050](https://insights.sbomify.com/CVE-2026-10050/): Digest authentication lossy encoding (high 8.7)
- [CVE-2025-5115](https://insights.sbomify.com/CVE-2025-5115/): MadeYouReset HTTP/2 vulnerability (high 7.7)
- [CVE-2024-7708](https://insights.sbomify.com/CVE-2024-7708/): Eclipse Jetty: DoS attack triggering OutOfMemory with 100-Continue requests (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-17638 and fix it if it is affected.

What it is: CVE-2019-17638 is a critical vulnerability in Eclipse Jetty, published on 9 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-17638 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.27; fixed in 9.4.30.v20200611
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.27; fixed in 9.4.30.v20200611

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-17638/ (Markdown: https://insights.sbomify.com/CVE-2019-17638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-17638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-17638
- OSV: https://osv.dev/vulnerability/CVE-2019-17638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-17638/
Summaries are generated and may contain mistakes; the official description above is the record.
