{"answers":{"affected":"2 open source packages ship an affected version, including class-validator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-18413 in the wild and no public exploit code.","fix":"Upgrade class-validator to 0.14.0 or later.","what":"CVE-2019-18413 is a low-severity missing authorization vulnerability in n/a, published on 24 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-18413 and fix it if it is affected.\n\nWhat it is: CVE-2019-18413 is a low-severity missing authorization vulnerability in n/a, published on 24 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-18413 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- class-validator (npm): affected all versions; fixed in 0.14.0\n- class-validator (npm): affected all versions; fixed in 0.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-18413/ (Markdown: https://insights.sbomify.com/CVE-2019-18413/index.md)","id":"CVE-2019-18413","markdown":"https://insights.sbomify.com/CVE-2019-18413/index.md","name":"CVE-2019-18413","record":{"aliases":["GHSA-fj58-h2fr-3pp2"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js validation library","requires_auth":"none","summary":"Attackers can bypass input validation in class-validator by overwriting internal attributes, potentially enabling SQL injection or XSS attacks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"typestack_class-validator","vendor":"typestack_class-validator_project"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AC:H/AV:N/A:N/C:N/I:L/PR:N/S:U/UI:N","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In TypeStack class-validator 0.10.2, validate() input validation can be bypassed because certain internal attributes can be overwritten via a conflicting name. Even though there is an optional forbidUnknownValues parameter that can be used to reduce the risk of this bypass, this option is not documented and thus most developers configure input validation in the vulnerable default manner. With this vulnerability, attackers can launch SQL Injection or XSS attacks by injecting arbitrary malicious input. NOTE: a software maintainer agrees with the \"is not documented\" finding but suggests that much of the responsibility for the risk lies in a different product.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQL Injection and Cross-site Scripting in class-validator","id":"CVE-2019-18413","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2019-18414"},"packages":[{"ecosystem":"npm","fixed":["0.14.0"],"introduced":["0"],"last_affected":[],"package":"class-validator","purl":null,"source":"GHSA-fj58-h2fr-3pp2"},{"ecosystem":"npm","fixed":["0.14.0"],"introduced":["0"],"last_affected":[],"package":"class-validator","purl":"pkg:npm/class-validator","source":"GHSA-fj58-h2fr-3pp2"}],"prev":{"headline":"XML external entity in n/a","id":"CVE-2019-18412"},"products":["n/a"],"published":"2019-10-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can bypass input validation in class-validator by overwriting internal attributes, potentially enabling SQL injection or XSS attacks.","url":"https://insights.sbomify.com/CVE-2019-18413/"}