{"answers":{"affected":"2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 4 products.","exploited":"There is no known exploitation of CVE-2019-18622 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to 4.9.2 or later.","what":"CVE-2019-18622 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 22 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-18622 and fix it if it is affected.\n\nWhat it is: CVE-2019-18622 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 22 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-18622 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 4.9.2\n- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 4.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-18622/ (Markdown: https://insights.sbomify.com/CVE-2019-18622/index.md)","id":"CVE-2019-18622","markdown":"https://insights.sbomify.com/CVE-2019-18622/index.md","name":"CVE-2019-18622","record":{"aliases":["DEBIAN-CVE-2019-18622","GHSA-jgjc-332c-8cmc","MGASA-2019-0357","openSUSE-SU-2019:2599-1"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Database administration tool","requires_auth":"none","summary":"Attackers can execute arbitrary SQL commands via crafted database or table names in the designer feature of phpMyAdmin.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"backports_sle","vendor":"opensuse"},{"product":"leap","vendor":"opensuse"},{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.","ecosystems":["Packagist","SUSE:Package Hub 12","SUSE:Package Hub 15","SUSE:Package Hub 15 SP1","openSUSE:Leap 15.0","openSUSE:Leap 15.1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQL injection in phpMyAdmin","id":"CVE-2019-18622","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:backports_sle","opensuse:leap","phpmyadmin:phpmyadmin"],"type":"sql_injection","year":"2019"},"n_packages":7,"n_references":6,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2019-18623"},"packages":[{"ecosystem":"Packagist","fixed":["4.9.2"],"introduced":["0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-jgjc-332c-8cmc"},{"ecosystem":"Packagist","fixed":["4.9.2"],"introduced":["0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-jgjc-332c-8cmc"},{"ecosystem":"SUSE:Package Hub 12","fixed":["4.9.2-bp151.3.9.1"],"introduced":["0"],"last_affected":[],"package":"phpMyAdmin","purl":"pkg:rpm/suse/phpMyAdmin\u0026distro=SUSE%20Package%20Hub%2012","source":"openSUSE-SU-2019:2599-1"},{"ecosystem":"SUSE:Package Hub 15","fixed":["4.9.2-bp151.3.9.1"],"introduced":["0"],"last_affected":[],"package":"phpMyAdmin","purl":"pkg:rpm/suse/phpMyAdmin\u0026distro=SUSE%20Package%20Hub%2015","source":"openSUSE-SU-2019:2599-1"},{"ecosystem":"SUSE:Package Hub 15 SP1","fixed":["4.9.2-bp151.3.9.1"],"introduced":["0"],"last_affected":[],"package":"phpMyAdmin","purl":"pkg:rpm/suse/phpMyAdmin\u0026distro=SUSE%20Package%20Hub%2015%20SP1","source":"openSUSE-SU-2019:2599-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["4.9.2-bp151.3.9.1"],"introduced":["0"],"last_affected":[],"package":"phpMyAdmin","purl":"pkg:rpm/opensuse/phpMyAdmin\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:2599-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["4.9.2-bp151.3.9.1"],"introduced":["0"],"last_affected":[],"package":"phpMyAdmin","purl":"pkg:rpm/opensuse/phpMyAdmin\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2019:2599-1"}],"prev":{"headline":"Other in n/a","id":"CVE-2019-18619"},"products":["n/a"],"published":"2019-11-22","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary SQL commands via crafted database or table names in the designer feature of phpMyAdmin.","url":"https://insights.sbomify.com/CVE-2019-18622/"}