# CVE-2019-18622: SQL injection in phpMyAdmin

> Attackers can execute arbitrary SQL commands via crafted database or table names in the designer feature of phpMyAdmin.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-18622, GHSA-jgjc-332c-8cmc, MGASA-2019-0357, openSUSE-SU-2019:2599-1

## What is CVE-2019-18622?

CVE-2019-18622 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 22 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2019-18622?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | All versions | 4.9.2 |
| `phpmyadmin/phpmyadmin` | Packagist | All versions | 4.9.2 |
| `phpMyAdmin` | SUSE:Package Hub 12 | All versions | 4.9.2-bp151.3.9.1 |
| `phpMyAdmin` | SUSE:Package Hub 15 | All versions | 4.9.2-bp151.3.9.1 |
| `phpMyAdmin` | SUSE:Package Hub 15 SP1 | All versions | 4.9.2-bp151.3.9.1 |
| `phpMyAdmin` | openSUSE:Leap 15.0 | All versions | 4.9.2-bp151.3.9.1 |
| `phpMyAdmin` | openSUSE:Leap 15.1 | All versions | 4.9.2-bp151.3.9.1 |

Products: Fedoraproject Fedora, Opensuse Backports Sle, Opensuse Leap, Phpmyadmin Phpmyadmin.

## How do I fix CVE-2019-18622?

Upgrade phpmyadmin/phpmyadmin to 4.9.2 or later.

## Is CVE-2019-18622 being exploited?

There is no known exploitation of CVE-2019-18622 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-18622 and fix it if it is affected.

What it is: CVE-2019-18622 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 22 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-18622 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 4.9.2
- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 4.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-18622/ (Markdown: https://insights.sbomify.com/CVE-2019-18622/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-18622
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-18622
- OSV: https://osv.dev/vulnerability/CVE-2019-18622

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-18622/
Summaries are generated and may contain mistakes; the official description above is the record.
