# CVE-2019-18643: File upload in n/a

> Attackers can bypass file extension blacklists to upload malicious ASPX code, achieving remote code execution with LocalSystem privileges.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Jan 2021
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8hmh-2f4f-8hr6

## What is CVE-2019-18643?

CVE-2019-18643 is a critical vulnerability in n/a, published on 7 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rock RMS versions before 8.10 and versions 9.0 through 9.3 fails to properly validate files uploaded in the application. The only protection mechanism is a file-extension blacklist that can be bypassed by adding multiple spaces and periods after the file name. This could allow an attacker to upload ASPX code and gain remote code execution on the application. The application typically runs as LocalSystem as mandated in the installation guide. Patched in versions 8.10 and 9.4.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2019-18643?

It affects 1 product.


Products: Sparkdevnetwork Rock Rms.

## How do I fix CVE-2019-18643?

No fix has been published for CVE-2019-18643 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-18643 being exploited?

There is no known exploitation of CVE-2019-18643 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-18642](https://insights.sbomify.com/CVE-2019-18642/): Business logic in n/a (critical 9.8)
- [CVE-2019-18641](https://insights.sbomify.com/CVE-2019-18641/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-18643 and fix it if it is affected.

What it is: CVE-2019-18643 is a critical vulnerability in n/a, published on 7 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-18643 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-18643/ (Markdown: https://insights.sbomify.com/CVE-2019-18643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-18643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-18643
- OSV: https://osv.dev/vulnerability/CVE-2019-18643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-18643/
Summaries are generated and may contain mistakes; the official description above is the record.
