CVE-2019-18658 Helm Unsafe Link Following
A malicious Helm chart can use symlinks to read sensitive files or cause denial of service when loaded or packaged by the client.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-18658?
CVE-2019-18658 is a critical path traversal vulnerability in n/a, published on 12 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Helm 2.x before 2.15.2, commands that deal with loading a chart as a directory or packaging a chart provide an opportunity for a maliciously designed chart to include sensitive content such as /etc/passwd, or to execute a denial of service (DoS) via a special file such as /dev/urandom, via symlinks. No version of Tiller is known to be impacted. This is a client-only issue.
Weakness: CWE-59
Which versions are affected by CVE-2019-18658?
3 open source packages ship an affected version, including helm.sh/helm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
helm.sh/helm Go | From 2.0.0 | 2.15.2 |
helm.sh/helm Go | From 2.0.0 | 2.15.2 |
helm.sh/helm Go | From 2.0.0+incompatible | 2.15.2+incompatible |
Linux distribution packages (4)
helm-mirror SUSE:Linux Enterprise Module for Containers 15 SP3 | All versions | 0.3.1-150000.1.13.1 |
helm-mirror SUSE:Linux Enterprise Module for Containers 15 SP4 | All versions | 0.3.1-150000.1.13.1 |
helm-mirror openSUSE:Leap 15.3 | All versions | 0.3.1-150000.1.13.1 |
helm-mirror openSUSE:Leap 15.4 | All versions | 0.3.1-150000.1.13.1 |
Products include Helm Helm.
How do I fix CVE-2019-18658?
Upgrade helm.sh/helm to a fixed version for your release line: 2.15.2 or 2.15.2+incompatible.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2019-18658 being exploited?
There is no known exploitation of CVE-2019-18658 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2019-1010275 Helm Improper Certificate Validation
- CVE-2019-25210 Information disclosure in n/a
- CVE-2025-53547 Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution
- CVE-2020-11013 lookup Function Information Discolosure in Helm
- CVE-2026-35204 Helm has a path traversal in plugin metadata version enables arbitrary file write outside Helm plugin directory
Sources
Also known as GHSA-p5pc-m4q7-7qm9, GO-2023-1938, SUSE-SU-2022:1888-1.