# CVE-2019-18658: Helm Unsafe Link Following

> A malicious Helm chart can use symlinks to read sensitive files or cause denial of service when loaded or packaged by the client.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-p5pc-m4q7-7qm9, GO-2023-1938, SUSE-SU-2022:1888-1

## What is CVE-2019-18658?

CVE-2019-18658 is a critical path traversal vulnerability in n/a, published on 12 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Helm 2.x before 2.15.2, commands that deal with loading a chart as a directory or packaging a chart provide an opportunity for a maliciously designed chart to include sensitive content such as /etc/passwd, or to execute a denial of service (DoS) via a special file such as /dev/urandom, via symlinks. No version of Tiller is known to be impacted. This is a client-only issue.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2019-18658?

3 open source packages ship an affected version, including helm.sh/helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm` | Go | From 2.0.0 | 2.15.2 |
| `helm.sh/helm` | Go | From 2.0.0 | 2.15.2 |
| `helm.sh/helm` | Go | From 2.0.0+incompatible | 2.15.2+incompatible |
| `helm-mirror` | SUSE:Linux Enterprise Module for Containers 15 SP3 | All versions | 0.3.1-150000.1.13.1 |
| `helm-mirror` | SUSE:Linux Enterprise Module for Containers 15 SP4 | All versions | 0.3.1-150000.1.13.1 |
| `helm-mirror` | openSUSE:Leap 15.3 | All versions | 0.3.1-150000.1.13.1 |
| `helm-mirror` | openSUSE:Leap 15.4 | All versions | 0.3.1-150000.1.13.1 |

Products: Helm Helm.

## How do I fix CVE-2019-18658?

Upgrade helm.sh/helm to a fixed version for your release line: 2.15.2 or 2.15.2+incompatible.

## Is CVE-2019-18658 being exploited?

There is no known exploitation of CVE-2019-18658 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)
- [CVE-2026-35204](https://insights.sbomify.com/CVE-2026-35204/): Helm has a path traversal in plugin metadata version enables arbitrary file write outside Helm plugin directory (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-18658 and fix it if it is affected.

What it is: CVE-2019-18658 is a critical path traversal vulnerability in n/a, published on 12 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-18658 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm (Go): affected from 2.0.0; fixed in 2.15.2
- helm.sh/helm (Go): affected from 2.0.0; fixed in 2.15.2
- helm.sh/helm (Go): affected from 2.0.0+incompatible; fixed in 2.15.2+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-18658/ (Markdown: https://insights.sbomify.com/CVE-2019-18658/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-18658
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-18658
- OSV: https://osv.dev/vulnerability/CVE-2019-18658

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-18658/
Summaries are generated and may contain mistakes; the official description above is the record.
