# CVE-2019-18817: Istio vulnerable to denial of service

> Attackers can cause a denial of service in Istio due to a timeout configuration issue in listener filters.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vc7h-cmp3-4hw5

## What is CVE-2019-18817?

CVE-2019-18817 is a high-severity denial of service vulnerability in n/a, published on 12 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Istio 1.3.x before 1.3.5 allows Denial of Service because continue_on_listener_filters_timeout is set to True, a related issue to CVE-2019-18836.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2019-18817?

2 open source packages ship an affected version, including istio.io/istio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `istio.io/istio` | Go | From 1.3.0 | 1.3.5 |
| `istio.io/istio` | Go | From 1.3.0 | 1.3.5 |

Products: Istio Istio.

## How do I fix CVE-2019-18817?

Upgrade istio.io/istio to 1.3.5 or later.

## Is CVE-2019-18817 being exploited?

There is no known exploitation of CVE-2019-18817 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-31921](https://insights.sbomify.com/CVE-2021-31921/): Missing authorization in n/a (critical 9.8)
- [CVE-2021-34824](https://insights.sbomify.com/CVE-2021-34824/): Information disclosure in n/a (high 8.8)
- [CVE-2026-31837](https://insights.sbomify.com/CVE-2026-31837/): Istio JWKS resolver to prevent private key material from being exposed when JWKS fetch fails. (high 8.7)
- [CVE-2021-39155](https://insights.sbomify.com/CVE-2021-39155/): Authorization Policy Bypass Due to Case Insensitive Host Comparison (high 8.3)
- [CVE-2021-39156](https://insights.sbomify.com/CVE-2021-39156/): Fragments in Path May Lead to Authorization Policy Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-18817 and fix it if it is affected.

What it is: CVE-2019-18817 is a high-severity denial of service vulnerability in n/a, published on 12 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-18817 in the wild and no public exploit code.

Affected packages and fixed versions:
- istio.io/istio (Go): affected from 1.3.0; fixed in 1.3.5
- istio.io/istio (Go): affected from 1.3.0; fixed in 1.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-18817/ (Markdown: https://insights.sbomify.com/CVE-2019-18817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-18817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-18817
- OSV: https://osv.dev/vulnerability/CVE-2019-18817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-18817/
Summaries are generated and may contain mistakes; the official description above is the record.
