# CVE-2019-18818: Strapi allows unauthenticated attacker to reset admin password without valid reset token

> Attackers can bypass password reset controls in Strapi to take over user accounts.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6xc2-mj39-q599

## What is CVE-2019-18818?

CVE-2019-18818 is a critical authentication bypass vulnerability in n/a, published on 7 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

strapi before 3.0.0-beta.17.5 mishandles password resets within packages/strapi-admin/controllers/Auth.js and packages/strapi-plugin-users-permissions/controllers/Auth.js.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2019-18818?

2 open source packages ship an affected version, including strapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `strapi` | npm | All versions | 3.0.0-beta.17.5 |
| `strapi` | npm | All versions | 3.0.0-beta.17.5 |

Products: Strapi Strapi.

## How do I fix CVE-2019-18818?

Upgrade strapi to 3.0.0-beta.17.5 or later.

## Is CVE-2019-18818 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-18818 exists.

Public exploit code:

- https://github.com/guglia001/CVE-2019-18818 (github_poc): https://github.com/guglia001/CVE-2019-18818
- Strapi 3.0.0-beta - Set Password (Unauthenticated) (exploitdb)
- https://github.com/rasyidfox/CVE-2019-18818 (github_poc): https://github.com/rasyidfox/CVE-2019-18818
- Strapi CMS 3.0.0-beta.17.4 - Set Password (Unauthenticated) (Metasploit) (exploitdb)
- Strapi CMS Unauthenticated Password Reset (metasploit)
- CVE-2019-18818/19606 Strapi RCE (github_poc): https://github.com/hadrian3689/strapi_cms_3.0.0-beta.17.7

## Other vulnerabilities in n/a

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2026-22599](https://insights.sbomify.com/CVE-2026-22599/): Strapi Vulnerable to SQL Injection in Content Type Builder (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-18818 and fix it if it is affected.

What it is: CVE-2019-18818 is a critical authentication bypass vulnerability in n/a, published on 7 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-18818 exists.

Affected packages and fixed versions:
- strapi (npm): affected all versions; fixed in 3.0.0-beta.17.5
- strapi (npm): affected all versions; fixed in 3.0.0-beta.17.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-18818/ (Markdown: https://insights.sbomify.com/CVE-2019-18818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-18818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-18818
- OSV: https://osv.dev/vulnerability/CVE-2019-18818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-18818/
Summaries are generated and may contain mistakes; the official description above is the record.
