# CVE-2019-18835: Improper Verification of Cryptographic Signature in matrix-synapse

> Attackers can bypass signature checks on federation APIs, allowing unsigned or spoofed events to be accepted by the Matrix Synapse server.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-cppw-2mf8-qpm5, PYSEC-2019-186, UBUNTU-CVE-2019-18835

## What is CVE-2019-18835?

CVE-2019-18835 is a critical vulnerability in n/a, published on 7 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2019-18835?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.5.0 |
| `matrix-synapse` | PyPI | All versions | 1.5.0 |
| `matrix-synapse` | PyPI | All versions | 1.5.0 |

Products: Matrix Synapse.

## How do I fix CVE-2019-18835?

Upgrade matrix-synapse to 1.5.0 or later.

## Is CVE-2019-18835 being exploited?

There is no known exploitation of CVE-2019-18835 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-52805](https://insights.sbomify.com/CVE-2024-52805/): Synapse allows unsupported content types to lead to memory exhaustion (high 8.2)
- [CVE-2024-53863](https://insights.sbomify.com/CVE-2024-53863/): Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders (high 8.2)
- [CVE-2024-37302](https://insights.sbomify.com/CVE-2024-37302/): Synapse denial of service through media disk space consumption (high 7.5)
- [CVE-2018-12423](https://insights.sbomify.com/CVE-2018-12423/): Matrix Synapse Authorization Error (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-18835 and fix it if it is affected.

What it is: CVE-2019-18835 is a critical vulnerability in n/a, published on 7 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-18835 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.5.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.5.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-18835/ (Markdown: https://insights.sbomify.com/CVE-2019-18835/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-18835
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-18835
- OSV: https://osv.dev/vulnerability/CVE-2019-18835

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-18835/
Summaries are generated and may contain mistakes; the official description above is the record.
