# CVE-2019-18841: Prototype Pollution in chartkick

> Prototype pollution in Chartkick.js allows attackers to inject properties into JavaScript objects, potentially leading to arbitrary code execution.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5pm8-492c-92p5

## What is CVE-2019-18841?

CVE-2019-18841 is a high-severity code injection vulnerability in n/a, published on 11 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Chartkick.js 3.1.0 through 3.1.3, as used in the Chartkick gem before 3.3.0 for Ruby, allows prototype pollution.

## Which versions are affected by CVE-2019-18841?

4 open source packages ship an affected version, including chartkick. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chartkick` | RubyGems | All versions | 3.3.0 |
| `chartkick` | RubyGems | All versions | 3.3.0 |
| `chartkick` | npm | From 3.1.0 | 3.2.0 |
| `chartkick` | npm | From 3.1.0 | 3.2.0 |

Products: Chartkick Chartkick.js.

## How do I fix CVE-2019-18841?

Upgrade chartkick to a fixed version for your release line: 3.3.0 or 3.2.0.

## Is CVE-2019-18841 being exploited?

There is no known exploitation of CVE-2019-18841 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-18841 and fix it if it is affected.

What it is: CVE-2019-18841 is a high-severity code injection vulnerability in n/a, published on 11 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-18841 in the wild and no public exploit code.

Affected packages and fixed versions:
- chartkick (RubyGems): affected all versions; fixed in 3.3.0
- chartkick (RubyGems): affected all versions; fixed in 3.3.0
- chartkick (npm): affected from 3.1.0; fixed in 3.2.0
- chartkick (npm): affected from 3.1.0; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-18841/ (Markdown: https://insights.sbomify.com/CVE-2019-18841/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-18841
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-18841
- OSV: https://osv.dev/vulnerability/CVE-2019-18841

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-18841/
Summaries are generated and may contain mistakes; the official description above is the record.
