CVE-2019-18844 Denial of service in n/a

High 7.5 Published Updated

Attackers can cause a denial of service in the ACRN hypervisor's PCI core via assertion failures triggered by specific inputs.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2019-18844?

CVE-2019-18844 is a high-severity denial of service vulnerability in n/a, published on 13 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Device Model in ACRN before 2019w25.5-140000p relies on assert calls in devicemodel/hw/pci/core.c and devicemodel/include/pci_core.h (instead of other mechanisms for propagating error information or diagnostic information), which might allow attackers to cause a denial of service (assertion failure) within pci core. This is fixed in 1.2. 6199e653418e is a mitigation for pre-1.1 versions, whereas 2b3dedfb9ba1 is a mitigation for 1.1.

Weakness: CWE-617

Which versions are affected by CVE-2019-18844?

It affects 1 product.

Products include Linux Acrn.

How do I fix CVE-2019-18844?

No fix has been published for CVE-2019-18844 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2019-18844 being exploited?

There is no known exploitation of CVE-2019-18844 in the wild and no public exploit code.

Sources

Also known as GHSA-3rh5-9p47-7947.

Is CVE-2019-18844 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free