{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-18844 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2019-18844 yet. Limit exposure of the affected software until one is available.","what":"CVE-2019-18844 is a high-severity denial of service vulnerability in n/a, published on 13 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-18844 and fix it if it is affected.\n\nWhat it is: CVE-2019-18844 is a high-severity denial of service vulnerability in n/a, published on 13 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-18844 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-18844/ (Markdown: https://insights.sbomify.com/CVE-2019-18844/index.md)","id":"CVE-2019-18844","markdown":"https://insights.sbomify.com/CVE-2019-18844/index.md","name":"CVE-2019-18844","record":{"aliases":["GHSA-3rh5-9p47-7947"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"ACRN hypervisor","requires_auth":"none","summary":"Attackers can cause a denial of service in the ACRN hypervisor's PCI core via assertion failures triggered by specific inputs.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"acrn","vendor":"linux"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-617","name":"Reachable Assertion"}],"description":"The Device Model in ACRN before 2019w25.5-140000p relies on assert calls in devicemodel/hw/pci/core.c and devicemodel/include/pci_core.h (instead of other mechanisms for propagating error information or diagnostic information), which might allow attackers to cause a denial of service (assertion failure) within pci core. This is fixed in 1.2. 6199e653418e is a mitigation for pre-1.1 versions, whereas 2b3dedfb9ba1 is a mitigation for 1.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Denial of service in n/a","id":"CVE-2019-18844","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":0,"n_references":5,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2019-18845"},"packages":[],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-18842"},"products":["n/a"],"published":"2019-11-13","related":[{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2021-36148","kev_date_added":null,"published":"2021-07-02"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2021-36143","kev_date_added":null,"published":"2021-07-02"},{"cvss_score":7.5,"headline":"Use after free in n/a","id":"CVE-2021-36144","kev_date_added":null,"published":"2021-07-02"},{"cvss_score":7.5,"headline":"Use after free in n/a","id":"CVE-2021-36145","kev_date_added":null,"published":"2021-07-02"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2021-36146","kev_date_added":null,"published":"2021-07-02"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2021-36147","kev_date_added":null,"published":"2021-07-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can cause a denial of service in the ACRN hypervisor's PCI core via assertion failures triggered by specific inputs.","url":"https://insights.sbomify.com/CVE-2019-18844/"}