# CVE-2019-18857: XSS in enshrined/svg-sanitize due to mishandled script and data values in attributes

> An attacker can execute arbitrary JavaScript via crafted SVG attributes due to improper sanitization of whitespace in script values.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-gf8j-v8x5-h9qp

## What is CVE-2019-18857?

CVE-2019-18857 is a high-severity cross-site scripting vulnerability in n/a, published on 11 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

darylldoyle svg-sanitizer before 0.12.0 mishandles script and data values in attributes, as demonstrated by unexpected whitespace such as in the javascript&#9;:alert substring.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-18857?

2 open source packages ship an affected version, including enshrined/svg-sanitize. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `enshrined/svg-sanitize` | Packagist | All versions | 0.12.0 |
| `enshrined/svg-sanitize` | Packagist | All versions | 0.12.0 |

Products: Svg-Sanitizer Project Svg-Sanitizer.

## How do I fix CVE-2019-18857?

Upgrade enshrined/svg-sanitize to 0.12.0 or later.

## Is CVE-2019-18857 being exploited?

There is no known exploitation of CVE-2019-18857 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-23638](https://insights.sbomify.com/CVE-2022-23638/): Cross-site Scripting in svg-sanitizer (medium 6.2)
- [CVE-2019-10772](https://insights.sbomify.com/CVE-2019-10772/): Sanitizer bypass in svg-sanitizer (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-18857 and fix it if it is affected.

What it is: CVE-2019-18857 is a high-severity cross-site scripting vulnerability in n/a, published on 11 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-18857 in the wild and no public exploit code.

Affected packages and fixed versions:
- enshrined/svg-sanitize (Packagist): affected all versions; fixed in 0.12.0
- enshrined/svg-sanitize (Packagist): affected all versions; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-18857/ (Markdown: https://insights.sbomify.com/CVE-2019-18857/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-18857
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-18857
- OSV: https://osv.dev/vulnerability/CVE-2019-18857

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-18857/
Summaries are generated and may contain mistakes; the official description above is the record.
