CVE-2019-18887 Symfony Http-Kernel has non-constant time comparison in UriSigner
Attackers can exploit timing attacks in Symfony's UriSigner to bypass security checks, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-18887?
CVE-2019-18887 is a high-severity vulnerability in Fedoraproject Fedora, published on 21 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Symfony 2.8.0 through 2.8.50, 3.4.0 through 3.4.34, 4.2.0 through 4.2.11, and 4.3.0 through 4.3.7. The UriSigner was subject to timing attacks. This is related to symfony/http-kernel.
Weakness: CWE-203
Which versions are affected by CVE-2019-18887?
16 open source packages ship an affected version, including symfony/http-kernel and symfony/symfony. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/http-kernel Packagist | From 2.2.0 | 2.8.52 |
symfony/http-kernel Packagist | From 2.2.0 | 2.8.52 |
symfony/http-kernel Packagist | From 3.0.0 | 3.4.35 |
symfony/http-kernel Packagist | From 3.0.0 | 3.4.35 |
symfony/http-kernel Packagist | From 4.0.0 | 4.2.12 |
symfony/http-kernel Packagist | From 4.0.0 | 4.2.12 |
10 more packages
symfony/http-kernel Packagist | From 4.3.0 | 4.3.8 |
symfony/http-kernel Packagist | From 4.3.0 | 4.3.8 |
symfony/symfony Packagist | From 2.2.0 | 2.8.52 |
symfony/symfony Packagist | From 2.2.0 | 2.8.52 |
symfony/symfony Packagist | From 3.0.0 | 3.4.35 |
symfony/symfony Packagist | From 3.0.0 | 3.4.35 |
symfony/symfony Packagist | From 4.0.0 | 4.2.12 |
symfony/symfony Packagist | From 4.0.0 | 4.2.12 |
symfony/symfony Packagist | From 4.3.0 | 4.3.8 |
symfony/symfony Packagist | From 4.3.0 | 4.3.8 |
Products include Fedoraproject Fedora, Sensiolabs Symfony.
How do I fix CVE-2019-18887?
Upgrade symfony/http-kernel to a fixed version for your release line: 2.8.52, 3.4.35, 4.2.12 or 4.3.8.
Is CVE-2019-18887 being exploited?
There is no known exploitation of CVE-2019-18887 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as DEBIAN-CVE-2019-18887, GHSA-q8hg-pf8v-cxrv, UBUNTU-CVE-2019-18887.