# CVE-2019-18887: Symfony Http-Kernel has non-constant time comparison in UriSigner

> Attackers can exploit timing attacks in Symfony's UriSigner to bypass security checks, requiring an upgrade to patched versions.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-18887, GHSA-q8hg-pf8v-cxrv, UBUNTU-CVE-2019-18887

## What is CVE-2019-18887?

CVE-2019-18887 is a high-severity vulnerability in Fedoraproject Fedora, published on 21 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Symfony 2.8.0 through 2.8.50, 3.4.0 through 3.4.34, 4.2.0 through 4.2.11, and 4.3.0 through 4.3.7. The UriSigner was subject to timing attacks. This is related to symfony/http-kernel.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2019-18887?

16 open source packages ship an affected version, including symfony/http-kernel and symfony/symfony. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/http-kernel` | Packagist | From 2.2.0 | 2.8.52 |
| `symfony/http-kernel` | Packagist | From 2.2.0 | 2.8.52 |
| `symfony/http-kernel` | Packagist | From 3.0.0 | 3.4.35 |
| `symfony/http-kernel` | Packagist | From 3.0.0 | 3.4.35 |
| `symfony/http-kernel` | Packagist | From 4.0.0 | 4.2.12 |
| `symfony/http-kernel` | Packagist | From 4.0.0 | 4.2.12 |
| `symfony/http-kernel` | Packagist | From 4.3.0 | 4.3.8 |
| `symfony/http-kernel` | Packagist | From 4.3.0 | 4.3.8 |
| `symfony/symfony` | Packagist | From 2.2.0 | 2.8.52 |
| `symfony/symfony` | Packagist | From 2.2.0 | 2.8.52 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.4.35 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.4.35 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.2.12 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.2.12 |
| `symfony/symfony` | Packagist | From 4.3.0 | 4.3.8 |
| `symfony/symfony` | Packagist | From 4.3.0 | 4.3.8 |

Products: Fedoraproject Fedora, Sensiolabs Symfony.

## How do I fix CVE-2019-18887?

Upgrade symfony/http-kernel to a fixed version for your release line: 2.8.52, 3.4.35, 4.2.12 or 4.3.8.

## Is CVE-2019-18887 being exploited?

There is no known exploitation of CVE-2019-18887 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-18887 and fix it if it is affected.

What it is: CVE-2019-18887 is a high-severity vulnerability in Fedoraproject Fedora, published on 21 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-18887 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/http-kernel (Packagist): affected from 2.2.0; fixed in 2.8.52
- symfony/http-kernel (Packagist): affected from 2.2.0; fixed in 2.8.52
- symfony/http-kernel (Packagist): affected from 3.0.0; fixed in 3.4.35
- symfony/http-kernel (Packagist): affected from 3.0.0; fixed in 3.4.35
- symfony/http-kernel (Packagist): affected from 4.0.0; fixed in 4.2.12
- symfony/http-kernel (Packagist): affected from 4.0.0; fixed in 4.2.12
- symfony/http-kernel (Packagist): affected from 4.3.0; fixed in 4.3.8
- symfony/http-kernel (Packagist): affected from 4.3.0; fixed in 4.3.8
- symfony/symfony (Packagist): affected from 2.2.0; fixed in 2.8.52
- symfony/symfony (Packagist): affected from 2.2.0; fixed in 2.8.52
- symfony/symfony (Packagist): affected from 3.0.0; fixed in 3.4.35
- symfony/symfony (Packagist): affected from 3.0.0; fixed in 3.4.35

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-18887/ (Markdown: https://insights.sbomify.com/CVE-2019-18887/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-18887
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-18887
- OSV: https://osv.dev/vulnerability/CVE-2019-18887

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-18887/
Summaries are generated and may contain mistakes; the official description above is the record.
