CVE-2019-18888 Argument injection in a MimeTypeGuesser in Symfony
Attackers can execute arbitrary commands by passing unvalidated input to MIME type validation in Symfony's HTTP Foundation component.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-18888?
CVE-2019-18888 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 21 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Symfony 2.8.0 through 2.8.50, 3.4.0 through 3.4.34, 4.2.0 through 4.2.11, and 4.3.0 through 4.3.7. If an application passes unvalidated user input as the file for which MIME type validation should occur, then arbitrary arguments are passed to the underlying file command. This is related to symfony/http-foundation (and symfony/mime in 4.3.x).
Weakness: CWE-88
Which versions are affected by CVE-2019-18888?
18 open source packages ship an affected version, including symfony/http-foundation, symfony/mime and symfony/symfony. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/http-foundation Packagist | From 2.0.0 | 2.8.52 |
symfony/http-foundation Packagist | From 2.0.0 | 2.8.52 |
symfony/http-foundation Packagist | From 3.0.0 | 3.4.35 |
symfony/http-foundation Packagist | From 3.0.0 | 3.4.35 |
symfony/http-foundation Packagist | From 4.0.0 | 4.2.12 |
symfony/http-foundation Packagist | From 4.0.0 | 4.2.12 |
12 more packages
symfony/http-foundation Packagist | From 4.3.0 | 4.3.8 |
symfony/http-foundation Packagist | From 4.3.0 | 4.3.8 |
symfony/mime Packagist | From 4.3.0 | 4.3.8 |
symfony/mime Packagist | From 4.3.0 | 4.3.8 |
symfony/symfony Packagist | From 2.0.0 | 2.8.52 |
symfony/symfony Packagist | From 2.0.0 | 2.8.52 |
symfony/symfony Packagist | From 3.0.0 | 3.4.35 |
symfony/symfony Packagist | From 3.0.0 | 3.4.35 |
symfony/symfony Packagist | From 4.0.0 | 4.2.12 |
symfony/symfony Packagist | From 4.0.0 | 4.2.12 |
symfony/symfony Packagist | From 4.3.0 | 4.3.8 |
symfony/symfony Packagist | From 4.3.0 | 4.3.8 |
Products include Fedoraproject Fedora, Sensiolabs Symfony.
How do I fix CVE-2019-18888?
Upgrade symfony/http-foundation to a fixed version for your release line: 2.8.52, 3.4.35, 4.2.12 or 4.3.8.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2019-18888 being exploited?
There is no known exploitation of CVE-2019-18888 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as DEBIAN-CVE-2019-18888, GHSA-xhh6-956q-4q69, UBUNTU-CVE-2019-18888.