{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-18898 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2019-18898 is a high-severity vulnerability in Opensuse Leap, published on 23 Jan 2020. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-18898 and fix it if it is affected.\n\nWhat it is: CVE-2019-18898 is a high-severity vulnerability in Opensuse Leap, published on 23 Jan 2020. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-18898 in the wild and no public exploit code.\n\nAffected product: Opensuse Leap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-18898/ (Markdown: https://insights.sbomify.com/CVE-2019-18898/index.md)","id":"CVE-2019-18898","markdown":"https://insights.sbomify.com/CVE-2019-18898/index.md","name":"CVE-2019-18898","record":{"aliases":["GHSA-w5w4-523j-qm3v","SUSE-SU-2019:3349-1","openSUSE-SU-2020:0015-1","openSUSE-SU-2020:0744-1"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Linux TPM library","requires_auth":"none","summary":"Local attackers can escalate privileges from user tss to root via symlink following in the trousers package.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"leap","vendor":"opensuse"},{"product":"trousers","vendor":"suse"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"UNIX Symbolic Link (Symlink) Following vulnerability in the trousers package of SUSE Linux Enterprise Server 15 SP1; openSUSE Factory allowed local attackers escalate privileges from user tss to root. This issue affects: SUSE Linux Enterprise Server 15 SP1 trousers versions prior to 0.3.14-6.3.1. openSUSE Factory trousers versions prior to 0.3.14-7.1.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP1","openSUSE:Leap 15.1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"trousers: Local privilege escalation from tss to root","id":"CVE-2019-18898","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:leap","products":["opensuse:leap"],"type":"privilege_escalation","year":"2019"},"n_packages":3,"n_references":2,"next":{"headline":"apt-cacher-ng insecure use of /run/apt-cacher-ng","id":"CVE-2019-18899"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP1","fixed":["0.3.14-6.3.1"],"introduced":["0"],"last_affected":[],"package":"trousers","purl":"pkg:rpm/suse/trousers\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP1","source":"SUSE-SU-2019:3349-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["0.3.14-lp151.4.3.1"],"introduced":["0"],"last_affected":[],"package":"trousers","purl":"pkg:rpm/opensuse/trousers\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2020:0015-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["0.3.14-lp151.4.6.1"],"introduced":["0"],"last_affected":[],"package":"trousers","purl":"pkg:rpm/opensuse/trousers\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2020:0744-1"}],"prev":{"headline":"Local privilege escalation from user salt to root","id":"CVE-2019-18897"},"products":["Factory","SUSE Linux Enterprise Server 15 SP1"],"published":"2020-01-23","related":[{"cvss_score":5.3,"headline":"Oracle Java SE Integrity Check","id":"CVE-2015-4902","kev_date_added":"2022-03-03","published":"2015-10-21"},{"cvss_score":9.9,"headline":"package builds could use directory traversal to write outside of target area","id":"CVE-2017-14804","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":9.8,"headline":"Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size.","id":"CVE-2019-20787","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-8341","kev_date_added":null,"published":"2019-02-15"},{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2019-6438","kev_date_added":null,"published":"2019-01-31"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-18215","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-6542","kev_date_added":null,"published":"2017-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["SUSE","openSUSE"]},"summary":"Local attackers can escalate privileges from user tss to root via symlink following in the trousers package.","url":"https://insights.sbomify.com/CVE-2019-18898/"}